Patchwork [04/17] perl-rdepends_5.14.2.inc:fix perl File::Glob module is broken

login
register
mail settings
Submitter Hongxu Jia
Date March 11, 2013, 11:04 a.m.
Message ID <f286b2b7465edf617d1c03e08fcd51d407f543ee.1362985569.git.hongxu.jia@windriver.com>
Download mbox | patch
Permalink /patch/45883/
State New
Headers show

Comments

Hongxu Jia - March 11, 2013, 11:04 a.m.
Update dependencies for perl modules again. When only install
perl-module-file-glob, run perl script with "require File::Glob;" will
fail. Update dependencies to fix that.

Cherry-pick commit c65e88b3f20627d7e49e0306f336eee3fb256d1e

[Yocto 3069]

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
---
 meta/recipes-devtools/perl/perl-rdepends_5.14.2.inc |    2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta/recipes-devtools/perl/perl-rdepends_5.14.2.inc b/meta/recipes-devtools/perl/perl-rdepends_5.14.2.inc
index 2707fe8..39972ca 100644
--- a/meta/recipes-devtools/perl/perl-rdepends_5.14.2.inc
+++ b/meta/recipes-devtools/perl/perl-rdepends_5.14.2.inc
@@ -13,8 +13,10 @@ 
 
 # Some additional dependencies that the above doesn't manage to figure out
 # Please take care that exporter depends exporter-heavy, not reverse
+RDEPENDS_${PN}-module-dynaloader += "${PN}-module-carp"
 RDEPENDS_${PN}-module-exporter += "${PN}-module-exporter-heavy"
 RDEPENDS_${PN}-module-file-glob += "${PN}-module-feature"
+RDEPENDS_${PN}-module-file-glob += "${PN}-module-file"
 RDEPENDS_${PN}-module-file-path += "${PN}-module-cwd"
 RDEPENDS_${PN}-module-file-spec += "${PN}-module-file-spec-unix"
 RDEPENDS_${PN}-module-file-stat += "${PN}-module-fcntl"