Patchwork buildhistory: Allow the version backwards check to be disabled

login
register
mail settings
Submitter Richard Purdie
Date March 3, 2013, 1:07 p.m.
Message ID <1362316038.4325.4.camel@ted>
Download mbox | patch
Permalink /patch/45449/
State Accepted
Commit 49f33a42e93711c96fbb099f3e6ee7f092d7b356
Headers show

Comments

Richard Purdie - March 3, 2013, 1:07 p.m.
When the PR service is not enabled, the versions can go backwards and there
are cases we don't want to know about this. This patch adds a variable
allowing these checks to be turned off whilst still using buildhistory.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---

Patch

diff --git a/meta/classes/buildhistory.bbclass b/meta/classes/buildhistory.bbclass
index a20d03d..43780ad 100644
--- a/meta/classes/buildhistory.bbclass
+++ b/meta/classes/buildhistory.bbclass
@@ -14,6 +14,7 @@  BUILDHISTORY_DIR_PACKAGE = "${BUILDHISTORY_DIR}/packages/${MULTIMACH_TARGET_SYS}
 BUILDHISTORY_COMMIT ?= "0"
 BUILDHISTORY_COMMIT_AUTHOR ?= "buildhistory <buildhistory@${DISTRO}>"
 BUILDHISTORY_PUSH_REPO ?= ""
+BUILDHISTORY_CHECKVERBACKWARDS ?= "1"
 
 # Must inherit package first before changing PACKAGEFUNCS
 inherit package
@@ -183,14 +184,15 @@  python buildhistory_emit_pkghistory() {
         # Find out what the last version was
         # Make sure the version did not decrease
         #
-        lastversion = getlastpkgversion(pkg)
-        if lastversion:
-            last_pkge = lastversion.pkge
-            last_pkgv = lastversion.pkgv
-            last_pkgr = lastversion.pkgr
-            r = bb.utils.vercmp((pkge, pkgv, pkgr), (last_pkge, last_pkgv, last_pkgr))
-            if r < 0:
-                bb.error("Package version for package %s went backwards which would break package feeds from (%s:%s-%s to %s:%s-%s)" % (pkg, last_pkge, last_pkgv, last_pkgr, pkge, pkgv, pkgr))
+        if d.getVar("BUILDHISTORY_CHECKVERBACKWARDS", True) == "1":
+            lastversion = getlastpkgversion(pkg)
+            if lastversion:
+                last_pkge = lastversion.pkge
+                last_pkgv = lastversion.pkgv
+                last_pkgr = lastversion.pkgr
+                r = bb.utils.vercmp((pkge, pkgv, pkgr), (last_pkge, last_pkgv, last_pkgr))
+                if r < 0:
+                    bb.error("Package version for package %s went backwards which would break package feeds from (%s:%s-%s to %s:%s-%s)" % (pkg, last_pkge, last_pkgv, last_pkgr, pkge, pkgv, pkgr))
 
         pkginfo = PackageInfo(pkg)
         # Apparently the version can be different on a per-package basis (see Python)