[meta-python] python3-pybind11: Override pip install variables

Message ID 20220228181413.2943079-1-tom.hochstein@nxp.com
State New
Headers show
Series [meta-python] python3-pybind11: Override pip install variables | expand

Commit Message

Tom Hochstein Feb. 28, 2022, 6:14 p.m. UTC
Fix the pip install variables since the default values don't work
here.

Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
---
 meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Khem Raj Feb. 28, 2022, 6:26 p.m. UTC | #1
please resend it to oe-devel ml.

On Mon, Feb 28, 2022 at 10:14 AM Tom Hochstein <tom.hochstein@nxp.com> wrote:
>
> Fix the pip install variables since the default values don't work
> here.
>
> Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
> ---
>  meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb
> index dfacb41f1..4d94e2033 100644
> --- a/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb
> +++ b/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb
> @@ -19,6 +19,9 @@ EXTRA_OECMAKE =  "-DPYBIND11_TEST=OFF"
>
>  inherit cmake setuptools3 python3native
>
> +PIP_INSTALL_DIST_PATH = "${S}/dist"
> +PIP_INSTALL_PACKAGE = "pybind11"
> +
>  do_configure() {
>         cmake_do_configure
>  }
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#162513): https://lists.openembedded.org/g/openembedded-core/message/162513
> Mute This Topic: https://lists.openembedded.org/mt/89457175/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb
index dfacb41f1..4d94e2033 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.8.1.bb
@@ -19,6 +19,9 @@  EXTRA_OECMAKE =  "-DPYBIND11_TEST=OFF"
 
 inherit cmake setuptools3 python3native
 
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+PIP_INSTALL_PACKAGE = "pybind11"
+
 do_configure() {
 	cmake_do_configure
 }