Patchwork [WR,1/2] Require git 1.7.7

login
register
mail settings
Submitter Mark Hatle
Date Feb. 7, 2013, 11:54 p.m.
Message ID <1360281263-23608-2-git-send-email-mark.hatle@windriver.com>
Download mbox | patch
Permalink /patch/44261/
State New
Headers show

Comments

Mark Hatle - Feb. 7, 2013, 11:54 p.m.
From: Jeff Polk <jeff.polk@windriver.com>

Due to some unique processes that we use, outside of OE-Core, we need
to mandate git 1.7.7 as the older allowed version.  This version contains
a fix that correctly handles reference clones which we use for our
RCPL updates.

Signed-off-by: Jeff Polk <jeff.polk@windriver.com>
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
---
 scripts/bitbake |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

Patch

diff --git a/scripts/bitbake b/scripts/bitbake
index 79a81ea..568a998 100755
--- a/scripts/bitbake
+++ b/scripts/bitbake
@@ -73,7 +73,8 @@  version_compare() {
 float_test "$TARVERSION > 1.23" && needtar="0"
 
 # Need git >= 1.7.5 for git-remote --mirror=xxx syntax
-version_compare $GITVERSION ">=" 1.7.5 && needgit="0"
+# WR: need git >= 1.7.7 for correct alternates handling
+version_compare $GITVERSION ">=" 1.7.7 && needgit="0"
 
 
 buildpseudo="1"