[meta-oe,5/6] guider: Set PYPA_WHEEL

Message ID 20220227075848.610467-5-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/6] python3-apt: Point PYPA_WHEEL to custom location | expand

Commit Message

Khem Raj Feb. 27, 2022, 7:58 a.m. UTC
Fixes build with wheels

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-devtools/guider/guider_3.9.8.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

akuster808 Feb. 27, 2022, 4:09 p.m. UTC | #1
On 2/26/22 23:58, Khem Raj wrote:
> Fixes build with wheels
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>   meta-oe/recipes-devtools/guider/guider_3.9.8.bb | 1 +
>   1 file changed, 1 insertion(+)
>
> diff --git a/meta-oe/recipes-devtools/guider/guider_3.9.8.bb b/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
> index 47d872a400..3c3f069df2 100644
> --- a/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
> +++ b/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
> @@ -14,6 +14,7 @@ SRCREV = "a502cd93b13235b7539557a91328de00b7c51bc3"
>   S = "${WORKDIR}/git"
>   
>   inherit setuptools3
> +PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-3.9.8-*.whl"
Any reason not to use PV here ?
>   
>   RDEPENDS:${PN} = "python3 python3-core \
>           python3-ctypes python3-shell python3-json"
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#95558): https://lists.openembedded.org/g/openembedded-devel/message/95558
> Mute This Topic: https://lists.openembedded.org/mt/89425252/3616698
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [akuster808@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Feb. 27, 2022, 9:11 p.m. UTC | #2
On Sun, Feb 27, 2022 at 8:09 AM akuster808 <akuster808@gmail.com> wrote:

>
>
> On 2/26/22 23:58, Khem Raj wrote:
> > Fixes build with wheels
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> >   meta-oe/recipes-devtools/guider/guider_3.9.8.bb | 1 +
> >   1 file changed, 1 insertion(+)
> >
> > diff --git a/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
> b/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
> > index 47d872a400..3c3f069df2 100644
> > --- a/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
> > +++ b/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
> > @@ -14,6 +14,7 @@ SRCREV = "a502cd93b13235b7539557a91328de00b7c51bc3"
> >   S = "${WORKDIR}/git"
> >
> >   inherit setuptools3
> > +PYPA_WHEEL =
> "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-3.9.8-*.whl"
> Any reason not to use PV here ?


PV is appended few lines above this code


PV = "3.9.8+git${SRCPV}"


> >
> >   RDEPENDS:${PN} = "python3 python3-core \
> >           python3-ctypes python3-shell python3-json"
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#95558):
> https://lists.openembedded.org/g/openembedded-devel/message/95558
> > Mute This Topic: https://lists.openembedded.org/mt/89425252/3616698
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> akuster808@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>

Patch

diff --git a/meta-oe/recipes-devtools/guider/guider_3.9.8.bb b/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
index 47d872a400..3c3f069df2 100644
--- a/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
+++ b/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
@@ -14,6 +14,7 @@  SRCREV = "a502cd93b13235b7539557a91328de00b7c51bc3"
 S = "${WORKDIR}/git"
 
 inherit setuptools3
+PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-3.9.8-*.whl"
 
 RDEPENDS:${PN} = "python3 python3-core \
         python3-ctypes python3-shell python3-json"