Patchwork [for-danny] gnomebase: depend on gnome-common-native

login
register
mail settings
Submitter Martin Jansa
Date Jan. 28, 2013, 10:31 a.m.
Message ID <1359369060-18964-1-git-send-email-Martin.Jansa@gmail.com>
Download mbox | patch
Permalink /patch/43523/
State Accepted, archived
Headers show

Comments

Martin Jansa - Jan. 28, 2013, 10:31 a.m.
From: Ross Burton <ross.burton@intel.com>

gnome-common is a build-only dependency so we should depend on the native
variant.  This also resolves an (incorrect) GPLv3 license issue in gnome-common
at build-time.

This will also remove the pointless gnome-common-dev RRECOMMENDS in any -dev
package that uses gnomebase.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
---
 meta/classes/gnomebase.bbclass | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/classes/gnomebase.bbclass b/meta/classes/gnomebase.bbclass
index 19c7f71..91c476c 100644
--- a/meta/classes/gnomebase.bbclass
+++ b/meta/classes/gnomebase.bbclass
@@ -7,7 +7,7 @@  GNOME_COMPRESS_TYPE ?= "bz2"
 SECTION ?= "x11/gnome"
 SRC_URI = "${GNOME_MIRROR}/${BPN}/${@gnome_verdir("${PV}")}/${BPN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive"
 
-DEPENDS += "gnome-common"
+DEPENDS += "gnome-common-native"
 
 FILES_${PN} += "${datadir}/application-registry  \
 	${datadir}/mime-info \