[meta-python] python3-pillow: fix wheel build

Message ID 20220226034044.1381510-1-tim.orling@konsulko.com
State New
Headers show
Series [meta-python] python3-pillow: fix wheel build | expand

Commit Message

Tim Orling Feb. 26, 2022, 3:40 a.m. UTC
Recipe does not inherit pypi nor would PN resolve to the name of the
wheel so we must set PIP_INSTALL_PACKAGE appropriately.

The recipe also builds its wheel in ${S}/dist so we must set
PIP_INSTALL_DIST_PATH appropriately.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb b/meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb
index de3c92c3d3..487e4b54c4 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb
@@ -13,6 +13,9 @@  SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
 
 inherit setuptools3
 
+PIP_INSTALL_PACKAGE = "Pillow"
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+
 DEPENDS += " \
     zlib \
     jpeg \