diff mbox series

[AUH] coreutils: upgrading to 9.5 SUCCEEDED

Message ID 0101018ee58a6bd0-c29b9902-e8b2-45a9-9ff5-9c176ee8097f-000000@us-west-2.amazonses.com
State New
Headers show
Series [AUH] coreutils: upgrading to 9.5 SUCCEEDED | expand

Commit Message

auh@yoctoproject.org April 16, 2024, 6:13 a.m. UTC
Hello,

this email is a notification from the Auto Upgrade Helper
that the automatic attempt to upgrade the recipe *coreutils* to *9.5* has Succeeded.

Next steps:
    - apply the patch: git am 0001-coreutils-upgrade-9.4-9.5.patch
    - check the changes to upstream patches and summarize them in the commit message,
    - compile an image that contains the package
    - perform some basic sanity tests
    - amend the patch and sign it off: git commit -s --reset-author --amend
    - send it to the appropriate mailing list

Alternatively, if you believe the recipe should not be upgraded at this time,
you can fill RECIPE_NO_UPDATE_REASON in respective recipe file so that
automatic upgrades would no longer be attempted.

Please review the attached files for further information and build/update failures.
Any problem please file a bug at https://bugzilla.yoctoproject.org/enter_bug.cgi?product=Automated%20Update%20Handler

Regards,
The Upgrade Helper

-- >8 --
From 8ef3ef9e142dc053283658b14a36fd51e097c1e5 Mon Sep 17 00:00:00 2001
From: Upgrade Helper <auh@yoctoproject.org>
Date: Mon, 15 Apr 2024 17:50:27 +0000
Subject: [PATCH] coreutils: upgrade 9.4 -> 9.5

---
 ...local.mk-fix-cross-compiling-problem.patch | 12 +++---
 .../0001-posixtm-pacify-clang-18.patch        | 38 ------------------
 .../coreutils/coreutils/CVE-2024-0684.patch   | 39 -------------------
 .../remove-usr-local-lib-from-m4.patch        |  7 ++--
 .../{coreutils_9.4.bb => coreutils_9.5.bb}    | 26 +++++++++++--
 5 files changed, 31 insertions(+), 91 deletions(-)
 delete mode 100644 meta/recipes-core/coreutils/coreutils/0001-posixtm-pacify-clang-18.patch
 delete mode 100644 meta/recipes-core/coreutils/coreutils/CVE-2024-0684.patch
 rename meta/recipes-core/coreutils/{coreutils_9.4.bb => coreutils_9.5.bb} (91%)
diff mbox series

Patch

diff --git a/meta/recipes-core/coreutils/coreutils/0001-local.mk-fix-cross-compiling-problem.patch b/meta/recipes-core/coreutils/coreutils/0001-local.mk-fix-cross-compiling-problem.patch
index 66f9a716c9..ce98e0bc80 100644
--- a/meta/recipes-core/coreutils/coreutils/0001-local.mk-fix-cross-compiling-problem.patch
+++ b/meta/recipes-core/coreutils/coreutils/0001-local.mk-fix-cross-compiling-problem.patch
@@ -1,4 +1,7 @@ 
-Subject: local.mk: fix cross compiling problem
+From d43fd3a8ad46e301cf9026447ceab4b0acadd31a Mon Sep 17 00:00:00 2001
+From: Chen Qi <Qi.Chen@windriver.com>
+Date: Mon, 26 Dec 2016 16:10:35 +0800
+Subject: [PATCH] local.mk: fix cross compiling problem
 
 We meet the following error when cross compiling.
 | Makefile:3418: *** Recursive variable 'INSTALL' references itself (eventually).  Stop.
@@ -12,15 +15,12 @@  Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/src/local.mk b/src/local.mk
-index 36dfa4e..c5898cc 100644
+index 96ee941..cdd47d6 100644
 --- a/src/local.mk
 +++ b/src/local.mk
-@@ -649,4 +649,4 @@ cu_install_program = @INSTALL_PROGRAM@
+@@ -704,4 +704,4 @@ cu_install_program = @INSTALL@
  else
  cu_install_program = src/ginstall
  endif
 -INSTALL = $(cu_install_program) -c
 +INSTALL_PROGRAM = $(cu_install_program)
--- 
-2.1.0
-
diff --git a/meta/recipes-core/coreutils/coreutils/0001-posixtm-pacify-clang-18.patch b/meta/recipes-core/coreutils/coreutils/0001-posixtm-pacify-clang-18.patch
deleted file mode 100644
index e6c84be3c4..0000000000
--- a/meta/recipes-core/coreutils/coreutils/0001-posixtm-pacify-clang-18.patch
+++ /dev/null
@@ -1,38 +0,0 @@ 
-From 67c298c36f69b6906840b7584be06b7b5f33f829 Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Tue, 16 Jan 2024 17:21:08 -0800
-Subject: [PATCH] posixtm: pacify clang 18
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Problem reported by Khem Raj in:
-https://lists.gnu.org/r/bug-gnulib/2024-01/msg00045.html
-* lib/posixtm.c (posixtime): Pacify clang 18 by converting bool to int.
-Arguably this is a bug in draft C2x, since the non-pointer args to
-ckd_add should promote just like any other expressions do;
-but that’s not clang’s fault.
-
-Upstream-Status: Submitted [https://lists.gnu.org/archive/html/bug-gnulib/2024-01/msg00046.html]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- ChangeLog     | 10 ++++++++++
- lib/posixtm.c |  2 +-
- 2 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/lib/posixtm.c b/lib/posixtm.c
-index ef9f55f873..a072c7cad0 100644
---- a/lib/posixtm.c
-+++ b/lib/posixtm.c
-@@ -191,7 +191,7 @@ posixtime (time_t *p, const char *s, unsigned int syntax_bits)
-              | (tm0.tm_min ^ tm1.tm_min)
-              | (tm0.tm_sec ^ tm1.tm_sec)))
-         {
--          if (ckd_add (&t, t, leapsec))
-+          if (ckd_add (&t, t, +leapsec))
-             return false;
-           *p = t;
-           return true;
--- 
-2.43.0
-
diff --git a/meta/recipes-core/coreutils/coreutils/CVE-2024-0684.patch b/meta/recipes-core/coreutils/coreutils/CVE-2024-0684.patch
deleted file mode 100644
index 0c68e2dce0..0000000000
--- a/meta/recipes-core/coreutils/coreutils/CVE-2024-0684.patch
+++ /dev/null
@@ -1,39 +0,0 @@ 
-From c4c5ed8f4e9cd55a12966d4f520e3a13101637d9 Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Tue, 16 Jan 2024 13:48:32 -0800
-Subject: [PATCH 1/1] split: do not shrink hold buffer
-MIME-Version: 1.0
-Content-Type: text/plain; charset=utf8
-Content-Transfer-Encoding: 8bit
-
-* src/split.c (line_bytes_split): Do not shrink hold buffer.
-If it’s large for this batch it’s likely to be large for the next
-batch, and for ‘split’ it’s not worth the complexity/CPU hassle to
-shrink it.  Do not assume hold_size can be bufsize.
-
-CVE: CVE-2024-0684
-Upstream-Status: Backport [https://github.com/coreutils/coreutils/commit/c4c5ed8f4e9cd55a12966d4f520e3a13101637d9]
-Signed-off-by: Simone Weiß <simone.p.weiss@posteo.com>
----
- src/split.c | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/src/split.c b/src/split.c
-index 64020c859..037960a59 100644
---- a/src/split.c
-+++ b/src/split.c
-@@ -809,10 +809,7 @@ line_bytes_split (intmax_t n_bytes, char *buf, idx_t bufsize)
-             {
-               cwrite (n_out == 0, hold, n_hold);
-               n_out += n_hold;
--              if (n_hold > bufsize)
--                hold = xirealloc (hold, bufsize);
-               n_hold = 0;
--              hold_size = bufsize;
-             }
- 
-           /* Output to eol if present.  */
--- 
-2.11.4.GIT
-
-
diff --git a/meta/recipes-core/coreutils/coreutils/remove-usr-local-lib-from-m4.patch b/meta/recipes-core/coreutils/coreutils/remove-usr-local-lib-from-m4.patch
index 1a8a9b9983..9ea81de0f7 100644
--- a/meta/recipes-core/coreutils/coreutils/remove-usr-local-lib-from-m4.patch
+++ b/meta/recipes-core/coreutils/coreutils/remove-usr-local-lib-from-m4.patch
@@ -1,4 +1,4 @@ 
-From a26530083a29eeee910bfd606ecc621acecd547a Mon Sep 17 00:00:00 2001
+From 131d257a8b8e2da6e0f2dc372d246473593e9852 Mon Sep 17 00:00:00 2001
 From: Khem Raj <raj.khem@gmail.com>
 Date: Wed, 3 Aug 2011 14:12:30 -0700
 Subject: [PATCH] coreutils: Fix build on uclibc
@@ -12,16 +12,15 @@  and make life easier for cross compilation process.
 Signed-off-by: Khem Raj <raj.khem@gmail.com>
 
 Upstream-Status: Inappropriate [Upstream does care for AIX while we may not]
-
 ---
  m4/getloadavg.m4 | 12 ------------
  1 file changed, 12 deletions(-)
 
 diff --git a/m4/getloadavg.m4 b/m4/getloadavg.m4
-index 8e96965..63782a2 100644
+index 9d0236f..68f7c52 100644
 --- a/m4/getloadavg.m4
 +++ b/m4/getloadavg.m4
-@@ -41,18 +41,6 @@ AC_CHECK_FUNC([getloadavg], [],
+@@ -46,18 +46,6 @@ if test $ac_cv_func_getloadavg != yes; then
         [LIBS="-lutil $LIBS" gl_func_getloadavg_done=yes])
     fi
  
diff --git a/meta/recipes-core/coreutils/coreutils_9.4.bb b/meta/recipes-core/coreutils/coreutils_9.5.bb
similarity index 91%
rename from meta/recipes-core/coreutils/coreutils_9.4.bb
rename to meta/recipes-core/coreutils/coreutils_9.5.bb
index 62ecdea6ec..386f17b11d 100644
--- a/meta/recipes-core/coreutils/coreutils_9.4.bb
+++ b/meta/recipes-core/coreutils/coreutils_9.5.bb
@@ -1,3 +1,23 @@ 
+# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
+# The following is the difference between the old and the new license text.
+# Please update the LICENSE value if needed, and summarize the changes in
+# the commit message via 'License-Update:' tag.
+# (example: 'License-Update: copyright years updated.')
+#
+# The changes:
+#
+# --- src/ls.c
+# +++ src/ls.c
+# @@ -1,5 +1,5 @@
+#  /* 'dir', 'vdir' and 'ls' directory listing programs for GNU.
+# -   Copyright (C) 1985-2023 Free Software Foundation, Inc.
+# +   Copyright (C) 1985-2024 Free Software Foundation, Inc.
+#  
+#     This program is free software: you can redistribute it and/or modify
+#     it under the terms of the GNU General Public License as published by
+# 
+#
+
 SUMMARY = "The basic file, shell and text manipulation utilities"
 DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
 manipulation utilities. These are the core utilities which are expected to exist on \
@@ -6,7 +26,7 @@  HOMEPAGE = "http://www.gnu.org/software/coreutils/"
 BUGTRACKER = "http://debbugs.gnu.org/coreutils"
 LICENSE = "GPL-3.0-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
-                    file://src/ls.c;beginline=1;endline=15;md5=b720a8b317035d66c555fc6d89e3674c \
+                    file://src/ls.c;beginline=1;endline=15;md5=9ac94aaed7fd46fd8df7147a9e3410cb \
                     "
 DEPENDS = "gmp libcap"
 DEPENDS:class-native = ""
@@ -16,11 +36,9 @@  inherit autotools gettext texinfo
 SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
            file://remove-usr-local-lib-from-m4.patch \
            file://0001-local.mk-fix-cross-compiling-problem.patch \
-           file://0001-posixtm-pacify-clang-18.patch \
-           file://CVE-2024-0684.patch \
            file://run-ptest \
            "
-SRC_URI[sha256sum] = "ea613a4cf44612326e917201bbbcdfbd301de21ffc3b59b6e5c07e040b275e52"
+SRC_URI[sha256sum] = "cd328edeac92f6a665de9f323c93b712af1858bc2e0d88f3f7100469470a1b8a"
 
 # http://git.savannah.gnu.org/cgit/coreutils.git/commit/?id=v8.27-101-gf5d7c0842
 #