diff mbox series

[meta-oe,1/2] docopt.cpp: turn boost to a PACKAGECONFIG option

Message ID 20240415113030.39050-1-eero.aaltonen@vaisala.com
State Accepted
Headers show
Series [meta-oe,1/2] docopt.cpp: turn boost to a PACKAGECONFIG option | expand

Commit Message

Aaltonen Eero April 15, 2024, 11:30 a.m. UTC
From: Eero Aaltonen <eero.aaltonen@vaisala.com>

docopt.cpp only uses boost regex with the option USE_BOOST_REGEX=ON.
When used, boost regex is statically linked.

Signed-off-by: Eero Aaltonen <eero.aaltonen@vaisala.com>
---
 meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
index 3d438871ed..87eed4b656 100644
--- a/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
+++ b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
@@ -13,7 +13,6 @@  LIC_FILES_CHKSUM = "\
     file://LICENSE-MIT;md5=4b242fd9ef20207e18286d73da8a6677 \
 "
 
-DEPENDS = "boost"
 SRCREV = "42ebcec9dc2c99a1b3a4542787572045763ad196"
 PV = "0.6.3+git"
 
@@ -24,3 +23,6 @@  SRC_URI = "\
 S = "${WORKDIR}/git"
 
 inherit cmake
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[boost] = "-DUSE_BOOST_REGEX=ON,-DUSE_BOOST_REGEX=OFF,boost"