diff mbox series

[meta-oe,1/4] unixodbc: Upgrade to 2.3.12

Message ID 20240413060653.2147909-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/4] unixodbc: Upgrade to 2.3.12 | expand

Commit Message

Khem Raj April 13, 2024, 6:06 a.m. UTC
Brings
Fix iconv handle leak with pooling
Add windows encoding patch
Avoid failed build if clock_gettime() is not available
Allow passing in a entire connection string into iusql
Allow isql to handle SQL_SUCCESS_WITH_INFO from SQLPrepare
Add extra logging for ODBCINST connect settings
Allow allocated copy (instead of fixed length) for the connection string with pooling to allow any length
Export __clear_ini_cache() from odbcinst to allow explicitly clearing the ini cache
Fix seg fault when used with SQLAPI
Add --enable-utf8ini flag to add utf8 to WCHAR conversions in SQLGetPrivateProfileStringW
Allow longer error messages via GetDiag functions
Add --enable-singleenv to enable single shared env handle when using pooling

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../unixodbc/{unixodbc_2.3.11.bb => unixodbc_2.3.12.bb}       | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-oe/recipes-support/unixodbc/{unixodbc_2.3.11.bb => unixodbc_2.3.12.bb} (89%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/unixodbc/unixodbc_2.3.11.bb b/meta-oe/recipes-support/unixodbc/unixodbc_2.3.12.bb
similarity index 89%
rename from meta-oe/recipes-support/unixodbc/unixodbc_2.3.11.bb
rename to meta-oe/recipes-support/unixodbc/unixodbc_2.3.12.bb
index 0ab4f8864d..ccdd666408 100644
--- a/meta-oe/recipes-support/unixodbc/unixodbc_2.3.11.bb
+++ b/meta-oe/recipes-support/unixodbc/unixodbc_2.3.12.bb
@@ -12,7 +12,7 @@  SRC_URI = "https://www.unixodbc.org/unixODBC-${PV}.tar.gz \
            file://do-not-use-libltdl-source-directory.patch \
            file://0001-exe-Makefile.am-add-CROSS_LAUNCHER-to-run-odbc_confi.patch \
 "
-SRC_URI[sha256sum] = "d9e55c8e7118347e3c66c87338856dad1516b490fb7c756c1562a2c267c73b5c"
+SRC_URI[sha256sum] = "f210501445ce21bf607ba51ef8c125e10e22dffdffec377646462df5f01915ec"
 
 UPSTREAM_CHECK_REGEX = "unixODBC-(?P<pver>\d+(\.\d+)+)\.tar"
 
@@ -44,5 +44,5 @@  do_install:prepend() {
 }
 
 do_install:append() {
-    oe_multilib_header unixodbc.h unixODBC/config.h unixODBC/unixodbc_conf.h
+    oe_multilib_header unixodbc.h unixODBC/unixodbc_conf.h
 }