diff mbox series

[meta-arago,master] weston-init: remove old qol patches

Message ID 20240412221350.542149-1-rs@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,master] weston-init: remove old qol patches | expand

Commit Message

Randolph Sapp April 12, 2024, 10:13 p.m. UTC
From: Randolph Sapp <rs@ti.com>

This reverts commit eab6e84b752b0341d1c1627527c99fa68c90bb52.

The changes introduced in this commit were accepted into oe-core and are
no longer required here.

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 .../wayland/weston-init.bbappend              |  8 --
 .../wayland/weston-init/weston-socket.sh      | 20 -----
 .../wayland/weston-init/weston.ini            | 73 +------------------
 3 files changed, 4 insertions(+), 97 deletions(-)
 delete mode 100755 meta-arago-distro/recipes-graphics/wayland/weston-init/weston-socket.sh
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-graphics/wayland/weston-init.bbappend b/meta-arago-distro/recipes-graphics/wayland/weston-init.bbappend
index be6b534b..4d5db58c 100644
--- a/meta-arago-distro/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-arago-distro/recipes-graphics/wayland/weston-init.bbappend
@@ -5,18 +5,10 @@  PR:append = ".arago12"
 SRC_URI:append = " \
     file://weston.ini \
     file://weston-launch-calibrator.sh \
-    file://weston-socket.sh \
 "
 
 do_install:append() {
     install -Dm755 weston-launch-calibrator.sh ${D}/${bindir}/weston-launch-calibrator
-
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -D -p -m0644 ${WORKDIR}/weston-socket.sh ${D}${sysconfdir}/profile.d/weston-socket.sh
-    fi
 }
 
 FILES:${PN}:append = "${bindir}/weston-launch-calibrator"
-
-GROUPADD_PARAM:${PN} = "-r wayland; -r render"
-USERADD_PARAM:${PN} = "--home /home/weston --shell /bin/sh --user-group -G video,input,render weston"
diff --git a/meta-arago-distro/recipes-graphics/wayland/weston-init/weston-socket.sh b/meta-arago-distro/recipes-graphics/wayland/weston-init/weston-socket.sh
deleted file mode 100755
index 86389d63..00000000
--- a/meta-arago-distro/recipes-graphics/wayland/weston-init/weston-socket.sh
+++ /dev/null
@@ -1,20 +0,0 @@ 
-#!/bin/sh
-
-# set weston variables for use with global weston socket
-global_socket="/run/wayland-0"
-if [ -e "$global_socket" ]; then
-	weston_group=$(stat -c "%G" "$global_socket")
-	if [ "$(id -u)" = "0" ]; then
-		export WAYLAND_DISPLAY="$global_socket"
-	else
-		case "$(groups "$USER")" in
-			*"$weston_group"*)
-				export WAYLAND_DISPLAY="$global_socket"
-				;;
-			*)
-				;;
-		esac
-	fi
-	unset weston_group
-fi
-unset global_socket
diff --git a/meta-arago-distro/recipes-graphics/wayland/weston-init/weston.ini b/meta-arago-distro/recipes-graphics/wayland/weston-init/weston.ini
index 8596346a..b9610fa8 100644
--- a/meta-arago-distro/recipes-graphics/wayland/weston-init/weston.ini
+++ b/meta-arago-distro/recipes-graphics/wayland/weston-init/weston.ini
@@ -1,10 +1,5 @@ 
-# configuration file for Weston
-
 [core]
 idle-time=0
-#modules=xwayland.so,cms-colord.so
-#shell=desktop-shell.so
-#gbm-format=xrgb2101010
 require-input=false
 
 [shell]
@@ -12,74 +7,14 @@  locking=false
 animation=zoom
 panel-position=top
 startup-animation=fade
-#background-image=/usr/share/backgrounds/gnome/Aqua.jpg
-#background-color=0xff002244
-#background-type=tile
-#clock-format=minutes
-#panel-color=0x90ff0000
-#locking=true
-#animation=zoom
-#startup-animation=fade
-#binding-modifier=ctrl
-#num-workspaces=6
-#cursor-theme=whiteglass
-#cursor-size=24
-
-#lockscreen-icon=/usr/share/icons/gnome/256x256/actions/lock.png
-#lockscreen=/usr/share/backgrounds/gnome/Garden.jpg
-#homescreen=/usr/share/backgrounds/gnome/Blinds.jpg
-#animation=fade
-
-#[launcher]
-#icon=/usr/share/icons/gnome/24x24/apps/utilities-terminal.png
-#path=/usr/bin/gnome-terminal
-
-#[launcher]
-#icon=/usr/share/icons/gnome/24x24/apps/utilities-terminal.png
-#path=/usr/bin/weston-terminal
-
-#[launcher]
-#icon=/usr/share/icons/hicolor/24x24/apps/google-chrome.png
-#path=/usr/bin/google-chrome
-
-#[launcher]
-#icon=/usr/share/icons/gnome/24x24/apps/arts.png
-#path=/build/weston-0lEgCh/weston-1.11.0/weston-flower
-
-#[input-method]
-#path=/usr/libexec/weston-keyboard
-
-#[output]
-#name=LVDS1
-#mode=1680x1050
-#transform=90
-#icc_profile=/usr/share/color/icc/colord/Bluish.icc
-
-#[output]
-#name=VGA1
-#mode=173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
-#transform=flipped
-
-#[output]
-#name=X1
-#mode=1024x768
-#transform=flipped-90
 
 [libinput]
 touchscreen_calibrator=true
-#enable_tap=true
-
-#[touchpad]
-#constant_accel_factor = 50
-#min_accel_factor = 0.16
-#max_accel_factor = 1.0
-
-[screen-share]
-command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize
-
-#[xwayland]
-#path=/usr/bin/Xwayland
 
 [autolaunch]
 # launch the calibrator on startup if a touchscreen is detected
 path=/usr/bin/weston-launch-calibrator
+
+[screensaver]
+# Uncomment path to disable screensaver
+#path=@libexecdir@/weston-screensaver