diff mbox series

[meta-python] python3-flexparser: enable ptest and add missing runtime dependencies

Message ID 20240411112318.167362-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-flexparser: enable ptest and add missing runtime dependencies | expand

Commit Message

alperak April 11, 2024, 11:23 a.m. UTC
* Ptest and library example tested on qemux86-64 and qemuarm64

* Add ptest into PTESTS_FAST_META_PYTHON

Ptest result:
=============

qemux86-64:

Testsuite summary
TOTAL: 59
PASS: 59
SKIP: 0
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 12
END: /usr/lib/python3-flexparser/ptest
2024-04-11T11:06
STOP: ptest-runner
TOTAL: 1 FAIL: 0

qemuarm64:

Testsuite summary
TOTAL: 59
PASS: 59
SKIP: 0
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 11
END: /usr/lib/python3-flexparser/ptest
2024-04-11T11:09
STOP: ptest-runner
TOTAL: 1 FAIL: 0

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../ptest-packagelists-meta-python.inc        |  1 +
 .../python/python3-flexparser/run-ptest       |  3 +++
 .../python/python3-flexparser_0.3.bb          | 22 ++++++++++++++++++-
 3 files changed, 25 insertions(+), 1 deletion(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-flexparser/run-ptest

Comments

Khem Raj April 11, 2024, 5:29 p.m. UTC | #1
thanks for doing this.

On Thu, Apr 11, 2024 at 4:23 AM Alper Ak <alperyasinak1@gmail.com> wrote:
>
> * Ptest and library example tested on qemux86-64 and qemuarm64
>
> * Add ptest into PTESTS_FAST_META_PYTHON
>
> Ptest result:
> =============
>
> qemux86-64:
>
> Testsuite summary
> TOTAL: 59
> PASS: 59
> SKIP: 0
> XFAIL: 0
> FAIL: 0
> XPASS: 0
> ERROR: 0
> DURATION: 12
> END: /usr/lib/python3-flexparser/ptest
> 2024-04-11T11:06
> STOP: ptest-runner
> TOTAL: 1 FAIL: 0
>
> qemuarm64:
>
> Testsuite summary
> TOTAL: 59
> PASS: 59
> SKIP: 0
> XFAIL: 0
> FAIL: 0
> XPASS: 0
> ERROR: 0
> DURATION: 11
> END: /usr/lib/python3-flexparser/ptest
> 2024-04-11T11:09
> STOP: ptest-runner
> TOTAL: 1 FAIL: 0
>
> Signed-off-by: alperak <alperyasinak1@gmail.com>
> ---
>  .../ptest-packagelists-meta-python.inc        |  1 +
>  .../python/python3-flexparser/run-ptest       |  3 +++
>  .../python/python3-flexparser_0.3.bb          | 22 ++++++++++++++++++-
>  3 files changed, 25 insertions(+), 1 deletion(-)
>  create mode 100644 meta-python/recipes-devtools/python/python3-flexparser/run-ptest
>
> diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
> index acb09aaca..6bd48156d 100644
> --- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
> +++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
> @@ -20,6 +20,7 @@ PTESTS_FAST_META_PYTHON = "\
>      python3-dominate \
>      python3-execnet \
>      python3-flexcache \
> +    python3-flexparser \
>      python3-freezegun \
>      python3-geojson \
>      python3-google-auth-oauthlib \
> diff --git a/meta-python/recipes-devtools/python/python3-flexparser/run-ptest b/meta-python/recipes-devtools/python/python3-flexparser/run-ptest
> new file mode 100644
> index 000000000..8d2017d39
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-flexparser/run-ptest
> @@ -0,0 +1,3 @@
> +#!/bin/sh
> +
> +pytest --automake
> diff --git a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
> index fb94235f0..e45175f5a 100644
> --- a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
> +++ b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
> @@ -6,6 +6,26 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
>  DEPENDS += "python3-setuptools-scm-native"
>  SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a"
>
> -inherit pypi python_setuptools_build_meta
> +inherit pypi python_setuptools_build_meta ptest
>
>  PYPI_PACKAGE = "flexparser"
> +
> +SRC_URI += " \
> +       file://run-ptest \
> +"
> +
> +RDEPENDS:${PN}-ptest += " \
> +       python3-pytest \
> +       python3-unittest-automake-output \
> +"
> +
> +do_install_ptest() {
> +       install -d ${D}${PTEST_PATH}/testsuite
> +       cp -rf ${S}/flexparser/testsuite/* ${D}${PTEST_PATH}/testsuite/
> +}
> +
> +RDEPENDS:${PN} += " \
> +       python3-compression \
> +       python3-email \
> +       python3-logging \
> +"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109919): https://lists.openembedded.org/g/openembedded-devel/message/109919
> Mute This Topic: https://lists.openembedded.org/mt/105460442/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
alperak April 11, 2024, 7:09 p.m. UTC | #2
You're welcome, I'm glad I could help! :)

Khem Raj <raj.khem@gmail.com>, 11 Nis 2024 Per, 20:29 tarihinde şunu yazdı:

> thanks for doing this.
>
> On Thu, Apr 11, 2024 at 4:23 AM Alper Ak <alperyasinak1@gmail.com> wrote:
> >
> > * Ptest and library example tested on qemux86-64 and qemuarm64
> >
> > * Add ptest into PTESTS_FAST_META_PYTHON
> >
> > Ptest result:
> > =============
> >
> > qemux86-64:
> >
> > Testsuite summary
> > TOTAL: 59
> > PASS: 59
> > SKIP: 0
> > XFAIL: 0
> > FAIL: 0
> > XPASS: 0
> > ERROR: 0
> > DURATION: 12
> > END: /usr/lib/python3-flexparser/ptest
> > 2024-04-11T11:06
> > STOP: ptest-runner
> > TOTAL: 1 FAIL: 0
> >
> > qemuarm64:
> >
> > Testsuite summary
> > TOTAL: 59
> > PASS: 59
> > SKIP: 0
> > XFAIL: 0
> > FAIL: 0
> > XPASS: 0
> > ERROR: 0
> > DURATION: 11
> > END: /usr/lib/python3-flexparser/ptest
> > 2024-04-11T11:09
> > STOP: ptest-runner
> > TOTAL: 1 FAIL: 0
> >
> > Signed-off-by: alperak <alperyasinak1@gmail.com>
> > ---
> >  .../ptest-packagelists-meta-python.inc        |  1 +
> >  .../python/python3-flexparser/run-ptest       |  3 +++
> >  .../python/python3-flexparser_0.3.bb          | 22 ++++++++++++++++++-
> >  3 files changed, 25 insertions(+), 1 deletion(-)
> >  create mode 100644
> meta-python/recipes-devtools/python/python3-flexparser/run-ptest
> >
> > diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc
> b/meta-python/conf/include/ptest-packagelists-meta-python.inc
> > index acb09aaca..6bd48156d 100644
> > --- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
> > +++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
> > @@ -20,6 +20,7 @@ PTESTS_FAST_META_PYTHON = "\
> >      python3-dominate \
> >      python3-execnet \
> >      python3-flexcache \
> > +    python3-flexparser \
> >      python3-freezegun \
> >      python3-geojson \
> >      python3-google-auth-oauthlib \
> > diff --git
> a/meta-python/recipes-devtools/python/python3-flexparser/run-ptest
> b/meta-python/recipes-devtools/python/python3-flexparser/run-ptest
> > new file mode 100644
> > index 000000000..8d2017d39
> > --- /dev/null
> > +++ b/meta-python/recipes-devtools/python/python3-flexparser/run-ptest
> > @@ -0,0 +1,3 @@
> > +#!/bin/sh
> > +
> > +pytest --automake
> > diff --git a/meta-python/recipes-devtools/python/
> python3-flexparser_0.3.bb b/meta-python/recipes-devtools/python/
> python3-flexparser_0.3.bb
> > index fb94235f0..e45175f5a 100644
> > --- a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
> > +++ b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
> > @@ -6,6 +6,26 @@ LIC_FILES_CHKSUM =
> "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
> >  DEPENDS += "python3-setuptools-scm-native"
> >  SRC_URI[sha256sum] =
> "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a"
> >
> > -inherit pypi python_setuptools_build_meta
> > +inherit pypi python_setuptools_build_meta ptest
> >
> >  PYPI_PACKAGE = "flexparser"
> > +
> > +SRC_URI += " \
> > +       file://run-ptest \
> > +"
> > +
> > +RDEPENDS:${PN}-ptest += " \
> > +       python3-pytest \
> > +       python3-unittest-automake-output \
> > +"
> > +
> > +do_install_ptest() {
> > +       install -d ${D}${PTEST_PATH}/testsuite
> > +       cp -rf ${S}/flexparser/testsuite/* ${D}${PTEST_PATH}/testsuite/
> > +}
> > +
> > +RDEPENDS:${PN} += " \
> > +       python3-compression \
> > +       python3-email \
> > +       python3-logging \
> > +"
> > --
> > 2.25.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#109919):
> https://lists.openembedded.org/g/openembedded-devel/message/109919
> > Mute This Topic: https://lists.openembedded.org/mt/105460442/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
diff mbox series

Patch

diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index acb09aaca..6bd48156d 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -20,6 +20,7 @@  PTESTS_FAST_META_PYTHON = "\
     python3-dominate \
     python3-execnet \
     python3-flexcache \
+    python3-flexparser \
     python3-freezegun \
     python3-geojson \
     python3-google-auth-oauthlib \
diff --git a/meta-python/recipes-devtools/python/python3-flexparser/run-ptest b/meta-python/recipes-devtools/python/python3-flexparser/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flexparser/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
index fb94235f0..e45175f5a 100644
--- a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
@@ -6,6 +6,26 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
 DEPENDS += "python3-setuptools-scm-native"
 SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a"
 
-inherit pypi python_setuptools_build_meta
+inherit pypi python_setuptools_build_meta ptest
 
 PYPI_PACKAGE = "flexparser"
+
+SRC_URI += " \
+	file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+	python3-pytest \
+	python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+	install -d ${D}${PTEST_PATH}/testsuite
+	cp -rf ${S}/flexparser/testsuite/* ${D}${PTEST_PATH}/testsuite/
+}
+
+RDEPENDS:${PN} += " \
+	python3-compression \
+	python3-email \
+	python3-logging \
+"