diff mbox series

[2/2] packagegroup-core-boot: recommend ifupdown

Message ID 20240411011745.574202-2-joe.slater@windriver.com
State Accepted, archived
Commit ad739fb930814bced49aafe778dac1da4bfa4b0e
Headers show
Series [1/2] init-ifupdown: modify interfaces for busybox | expand

Commit Message

Slater, Joseph April 11, 2024, 1:17 a.m. UTC
From: Joe Slater <joe.slater@windriver.com>

If the distro features sysvinit and pni-names are
enabled, RRECOMMENDS ifupdown because busybox ifupdown
will not initialize the renamed interfaces.

Signed-off-by: Joe Slater <joe.slater@windriver.com>
---
 .../init-ifupdown/init-ifupdown-1.0/qemuall/interfaces       | 5 -----
 meta/recipes-core/packagegroups/packagegroup-core-boot.bb    | 4 +++-
 2 files changed, 3 insertions(+), 6 deletions(-)
 delete mode 100644 meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces

Comments

Richard Purdie April 11, 2024, 9:33 a.m. UTC | #1
On Wed, 2024-04-10 at 18:17 -0700, Joe Slater via lists.openembedded.org wrote:
> From: Joe Slater <joe.slater@windriver.com>
> 
> If the distro features sysvinit and pni-names are
> enabled, RRECOMMENDS ifupdown because busybox ifupdown
> will not initialize the renamed interfaces.
> 
> Signed-off-by: Joe Slater <joe.slater@windriver.com>
> ---
>  .../init-ifupdown/init-ifupdown-1.0/qemuall/interfaces       | 5 -----
>  meta/recipes-core/packagegroups/packagegroup-core-boot.bb    | 4 +++-
>  2 files changed, 3 insertions(+), 6 deletions(-)
>  delete mode 100644 meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces
> 
> diff --git a/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces b/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces
> deleted file mode 100644
> index 16967763e5..0000000000
> --- a/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces
> +++ /dev/null
> @@ -1,5 +0,0 @@
> -# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
> - 
> -# The loopback interface
> -auto lo
> -iface lo inet loopback

Is this patch meant to touch ifupdown as well as the packagegroup?

> diff --git a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
> index d96d2f5fff..fecc3334ea 100644
> --- a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
> +++ b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
> @@ -37,4 +37,6 @@ RDEPENDS:${PN} = "\
>  RRECOMMENDS:${PN} = "\
>      ${VIRTUAL-RUNTIME_base-utils-syslog} \
>      ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \
> -    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "init-ifupdown", "", d)}"
> +    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "init-ifupdown", "", d)} \
> +    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit pni-names", "ifupdown", "", d)} \
> +    "

Cheers,

Richard
Ross Burton April 11, 2024, 2:20 p.m. UTC | #2
On 11 Apr 2024, at 10:33, Richard Purdie via lists.openembedded.org <richard.purdie=linuxfoundation.org@lists.openembedded.org> wrote:
>> --- a/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces
>> +++ /dev/null
>> @@ -1,5 +0,0 @@
>> -# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
>> - 
>> -# The loopback interface
>> -auto lo
>> -iface lo inet loopback
> 
> Is this patch meant to touch ifupdown as well as the packagegroup?

I suspect not, given that runqemu manually brings up network devices and the last thing we want is DHCP running again.

Joe, please remove this chunk.

Ross
Slater, Joseph April 11, 2024, 2:58 p.m. UTC | #3
> -----Original Message-----
> From: Ross Burton <Ross.Burton@arm.com>
> Sent: Thursday, April 11, 2024 7:21 AM
> To: Richard Purdie <richard.purdie@linuxfoundation.org>; Slater, Joseph
> <joe.slater@windriver.com>
> Cc: OE-core <openembedded-core@lists.openembedded.org>; MacLeod, Randy
> <Randy.MacLeod@windriver.com>
> Subject: Re: [oe-core][PATCH 2/2] packagegroup-core-boot: recommend
> ifupdown
> 
> On 11 Apr 2024, at 10:33, Richard Purdie via lists.openembedded.org
> <richard.purdie=linuxfoundation.org@lists.openembedded.org> wrote:
> >> --- a/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces
> >> +++ /dev/null
> >> @@ -1,5 +0,0 @@
> >> -# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
> >> -
> >> -# The loopback interface
> >> -auto lo
> >> -iface lo inet loopback
> >
> > Is this patch meant to touch ifupdown as well as the packagegroup?
> 
> I suspect not, given that runqemu manually brings up network devices and the
> last thing we want is DHCP running again.
> 
> Joe, please remove this chunk.

This was accidental since I removed the qemuall/interfaces in order to use the main one with qemu.  I'm sending new patches.  Maybe, though, we don't really need the qemuall stuff.

Joe
> 
> Ross
Ross Burton April 11, 2024, 4:36 p.m. UTC | #4
On 11 Apr 2024, at 15:58, Joe Slater via lists.openembedded.org <joe.slater=windriver.com@lists.openembedded.org> wrote:
> This was accidental since I removed the qemuall/interfaces in order to use the main one with qemu.  I'm sending new patches.  Maybe, though, we don't really need the qemuall stuff.

The last time I looked we did need it, because testimage will manually setup the network interface with known IPs via kernel parameters.  The last thing we need is for ifupdown to decide to take over the interface and reconfigure it.

Ross
Alexandre Belloni April 12, 2024, 10:21 a.m. UTC | #5
On 11/04/2024 14:58:40+0000, Joe Slater via lists.openembedded.org wrote:
> 
> 
> > -----Original Message-----
> > From: Ross Burton <Ross.Burton@arm.com>
> > Sent: Thursday, April 11, 2024 7:21 AM
> > To: Richard Purdie <richard.purdie@linuxfoundation.org>; Slater, Joseph
> > <joe.slater@windriver.com>
> > Cc: OE-core <openembedded-core@lists.openembedded.org>; MacLeod, Randy
> > <Randy.MacLeod@windriver.com>
> > Subject: Re: [oe-core][PATCH 2/2] packagegroup-core-boot: recommend
> > ifupdown
> > 
> > On 11 Apr 2024, at 10:33, Richard Purdie via lists.openembedded.org
> > <richard.purdie=linuxfoundation.org@lists.openembedded.org> wrote:
> > >> --- a/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces
> > >> +++ /dev/null
> > >> @@ -1,5 +0,0 @@
> > >> -# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
> > >> -
> > >> -# The loopback interface
> > >> -auto lo
> > >> -iface lo inet loopback
> > >
> > > Is this patch meant to touch ifupdown as well as the packagegroup?
> > 
> > I suspect not, given that runqemu manually brings up network devices and the
> > last thing we want is DHCP running again.
> > 
> > Joe, please remove this chunk.
> 
> This was accidental since I removed the qemuall/interfaces in order to use the main one with qemu.  I'm sending new patches.  Maybe, though, we don't really need the qemuall stuff.

This broke all the tests of this build:

https://autobuilder.yoctoproject.org/typhoon/#/builders/83/builds/6786

> 
> Joe
> > 
> > Ross

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#198136): https://lists.openembedded.org/g/openembedded-core/message/198136
> Mute This Topic: https://lists.openembedded.org/mt/105454861/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Slater, Joseph April 12, 2024, 4:15 p.m. UTC | #6
> -----Original Message-----
> From: Alexandre Belloni <alexandre.belloni@bootlin.com>
> Sent: Friday, April 12, 2024 3:22 AM
> To: Slater, Joseph <joe.slater@windriver.com>
> Cc: Ross Burton <Ross.Burton@arm.com>; Richard Purdie
> <richard.purdie@linuxfoundation.org>; OE-core <openembedded-
> core@lists.openembedded.org>; MacLeod, Randy
> <Randy.MacLeod@windriver.com>
> Subject: Re: [oe-core][PATCH 2/2] packagegroup-core-boot: recommend
> ifupdown
> 
> On 11/04/2024 14:58:40+0000, Joe Slater via lists.openembedded.org wrote:
> >
> >
> > > -----Original Message-----
> > > From: Ross Burton <Ross.Burton@arm.com>
> > > Sent: Thursday, April 11, 2024 7:21 AM
> > > To: Richard Purdie <richard.purdie@linuxfoundation.org>; Slater,
> > > Joseph <joe.slater@windriver.com>
> > > Cc: OE-core <openembedded-core@lists.openembedded.org>; MacLeod,
> > > Randy <Randy.MacLeod@windriver.com>
> > > Subject: Re: [oe-core][PATCH 2/2] packagegroup-core-boot: recommend
> > > ifupdown
> > >
> > > On 11 Apr 2024, at 10:33, Richard Purdie via lists.openembedded.org
> > > <richard.purdie=linuxfoundation.org@lists.openembedded.org> wrote:
> > > >> ---
> > > >> a/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/inter
> > > >> faces
> > > >> +++ /dev/null
> > > >> @@ -1,5 +0,0 @@
> > > >> -# /etc/network/interfaces -- configuration file for ifup(8),
> > > >> ifdown(8)
> > > >> -
> > > >> -# The loopback interface
> > > >> -auto lo
> > > >> -iface lo inet loopback
> > > >
> > > > Is this patch meant to touch ifupdown as well as the packagegroup?
> > >
> > > I suspect not, given that runqemu manually brings up network devices
> > > and the last thing we want is DHCP running again.
> > >
> > > Joe, please remove this chunk.
> >
> > This was accidental since I removed the qemuall/interfaces in order to use the
> main one with qemu.  I'm sending new patches.  Maybe, though, we don't really
> need the qemuall stuff.
> 
> This broke all the tests of this build:
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/83/builds/6786

The V2 patch doesn't change the interfaces file and should not cause any issues.

Joe

> 
> >
> > Joe
> > >
> > > Ross
> 
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#198136):
> > https://lists.openembedded.org/g/openembedded-core/message/198136
> > Mute This Topic: https://lists.openembedded.org/mt/105454861/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub
> > [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
> 
> 
> --
> Alexandre Belloni, co-owner and COO, Bootlin Embedded Linux and Kernel
> engineering https://bootlin.com
diff mbox series

Patch

diff --git a/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces b/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces
deleted file mode 100644
index 16967763e5..0000000000
--- a/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/qemuall/interfaces
+++ /dev/null
@@ -1,5 +0,0 @@ 
-# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
- 
-# The loopback interface
-auto lo
-iface lo inet loopback
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
index d96d2f5fff..fecc3334ea 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
@@ -37,4 +37,6 @@  RDEPENDS:${PN} = "\
 RRECOMMENDS:${PN} = "\
     ${VIRTUAL-RUNTIME_base-utils-syslog} \
     ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \
-    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "init-ifupdown", "", d)}"
+    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "init-ifupdown", "", d)} \
+    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit pni-names", "ifupdown", "", d)} \
+    "