diff mbox series

[meta-python] python3-ecdsa: upgrade 0.18.0 -> 0.19.0

Message ID 20240410225118.1033624-1-gudnimar@noxmedical.com
State Accepted
Headers show
Series [meta-python] python3-ecdsa: upgrade 0.18.0 -> 0.19.0 | expand

Commit Message

Guðni Már Gilbert April 10, 2024, 10:51 p.m. UTC
Changelog:
==========
New API:
------------
    to_ssh in VerifyingKey and SigningKey, supports Ed25519 keys only (Pablo Mazzini)

New features:
------------
    Support for twisted Brainpool curves

Doc fix:
------------
    Fix curve equation in glossary
    Documentation for signature encoding and signature decoding functions

Maintenance:
------------
    Dropped official support for 3.3 and 3.4 (because of problems running them
    in CI, not because it's actually incompatible; support for 2.6 and 2.7 is
    unaffected)
    Fixes around hypothesis parameters
    Officially support Python 3.11 and 3.12
    Small updates to test suite to make it work with 3.11 and 3.12 and new
    releases of test dependencies
    Dropped the internal _rwlock module as it's unused
    Added mutation testing to CI, lots of speed-ups to the test suite
    to make it happen
    Removal of unnecessary six.b literals (Alexandre Detiste)

Deprecations:
------------
    int_to_string, string_to_int, and digest_integer from ecdsa.ecdsa
    module are now considered deprecated, they will be removed in a future
    release

Signed-off-by: Guðni Már Gilbert <gudnimar@noxmedical.com>
---
 .../python/{python3-ecdsa_0.18.0.bb => python3-ecdsa_0.19.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-ecdsa_0.18.0.bb => python3-ecdsa_0.19.0.bb} (82%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.18.0.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
similarity index 82%
rename from meta-python/recipes-devtools/python/python3-ecdsa_0.18.0.bb
rename to meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
index 12dd51e79..5b4f7eb93 100644
--- a/meta-python/recipes-devtools/python/python3-ecdsa_0.18.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
@@ -4,7 +4,7 @@  LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
 
 PYPI_PACKAGE = "ecdsa"
-SRC_URI[sha256sum] = "190348041559e21b22a1d65cee485282ca11a6f81d503fddb84d5017e9ed1e49"
+SRC_URI[sha256sum] = "60eaad1199659900dd0af521ed462b793bbdf867432b3948e87416ae4caf6bf8"
 
 inherit pypi setuptools3 python3native