diff mbox series

[meta-raspberrypi,2/3] u-boot: re-enable rapsberrypi5

Message ID 16dcfcd6ee331d712e3cc7c0cdf2b0f85c33e8af.1712518899.git.tim.orling@konsulko.com
State New
Headers show
Series [meta-raspberrypi,1/3] layer.conf: rpi5 recommends lts-u-boot-mixin | expand

Commit Message

Tim Orling April 7, 2024, 7:54 p.m. UTC
With meta-lts-mixins scarthgap/u-boot we can now support raspberrypi5

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 conf/machine/raspberrypi5.conf       | 2 ++
 recipes-bsp/u-boot/u-boot_%.bbappend | 3 ---
 2 files changed, 2 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/conf/machine/raspberrypi5.conf b/conf/machine/raspberrypi5.conf
index 8c38637..e53c2d5 100644
--- a/conf/machine/raspberrypi5.conf
+++ b/conf/machine/raspberrypi5.conf
@@ -24,3 +24,5 @@  VC4DTBO ?= "vc4-kms-v3d"
 
 # "zImage" not supported on arm64 and ".gz" images not supported by bootloader yet
 KERNEL_IMAGETYPE_DIRECT ?= "Image"
+
+UBOOT_MACHINE = "rpi_arm64_config"
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index 78b3e48..e50acf5 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -12,6 +12,3 @@  do_install:append:rpi () {
     install -d ${D}${sysconfdir}
     install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
 }
-
-# Temporary avoid Raspberry Pi 5 because U-Boot has not been ported yet
-COMPATIBLE_MACHINE:raspberrypi5 = "(-)"