diff mbox series

[2/2] libseccomp: Fix build when python packageconfig is enabled

Message ID 20240406171047.1527823-2-raj.khem@gmail.com
State Accepted, archived
Commit c3568ee00d3b7f6b421020dfec8005a27c2e9164
Headers show
Series [1/2] llvm: Upgrade to 18.1.3 bugfix release | expand

Commit Message

Khem Raj April 6, 2024, 5:10 p.m. UTC
It needs additional tweaks with python enabled

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-support/libseccomp/libseccomp_2.5.5.bb | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-support/libseccomp/libseccomp_2.5.5.bb b/meta/recipes-support/libseccomp/libseccomp_2.5.5.bb
index 06ba5e9c98e..478e5f4289e 100644
--- a/meta/recipes-support/libseccomp/libseccomp_2.5.5.bb
+++ b/meta/recipes-support/libseccomp/libseccomp_2.5.5.bb
@@ -17,10 +17,12 @@  S = "${WORKDIR}/git"
 
 inherit autotools-brokensep pkgconfig ptest features_check
 
+inherit_defer ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
+
 REQUIRED_DISTRO_FEATURES = "seccomp"
 
 PACKAGECONFIG ??= ""
-PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
+PACKAGECONFIG[python] = "--enable-python, --disable-python, python3-cython-native"
 
 DISABLE_STATIC = ""
 
@@ -48,9 +50,13 @@  do_install_ptest() {
     for file in $(find tools/.libs/* -executable -type f); do
         install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
     done
+     # fix python shebang
+     sed -i -e 's@cmd /usr/bin/env python @cmd /usr/bin/env python3 @' ${D}/${PTEST_PATH}/tests/regression
+     sed -i -e 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@' ${D}/${PTEST_PATH}/tests/*.py
 }
 
-FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*"
+FILES:${PN} = "${bindir} ${libdir}/${BPN}.so* ${PYTHON_SITEPACKAGES_DIR}/"
 FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
 
+RDEPENDS:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3', '', d)}"
 RDEPENDS:${PN}-ptest = "coreutils bash"