diff mbox series

yocto-bsp/linux-yocto-dev: add genericarm64

Message ID 20240405135649.2128367-1-jdmason@kudzu.us (mailing list archive)
State New
Headers show
Series yocto-bsp/linux-yocto-dev: add genericarm64 | expand

Commit Message

Jon Mason April 5, 2024, 1:56 p.m. UTC
For those crazy enough to want to use/test the latest development kernel
for genericarm64, enable it by adding the COMPATIBLE_MACHINE and
KMACHINE.

NOTE: not using the KBRANCH, as neither does the linux-yocto_%.bbappend.
It is taking the default one from the relevant recipe.

Signed-off-by: Jon Mason <jdmason@kudzu.us>
---
 meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
index 4a62ac952c46..5b1b736b1cc0 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -2,10 +2,12 @@  KBRANCH:genericx86  = "standard/base"
 KBRANCH:genericx86-64  = "standard/base"
 KBRANCH:beaglebone-yocto = "standard/beaglebone"
 
+KMACHINE:genericarm64 ?= "genericarm64"
 KMACHINE:genericx86 ?= "common-pc"
 KMACHINE:genericx86-64 ?= "common-pc-64"
 KMACHINE:beaglebone-yocto ?= "beaglebone"
 
+COMPATIBLE_MACHINE:genericarm64 = "genericarm64"
 COMPATIBLE_MACHINE:genericx86 = "genericx86"
 COMPATIBLE_MACHINE:genericx86-64 = "genericx86-64"
 COMPATIBLE_MACHINE:beaglebone-yocto = "beaglebone-yocto"