diff mbox series

[meta-python] python3-twisted: Add python3-asyncio to RDEPENDS

Message ID 20240404185750.3570-1-gudnimar@noxmedical.com
State New
Headers show
Series [meta-python] python3-twisted: Add python3-asyncio to RDEPENDS | expand

Commit Message

Guðni Már Gilbert April 4, 2024, 6:57 p.m. UTC
From: Hains van den Bosch <hainsvdbosch@ziggo.nl>

To fix crash due to missing module:

from twisted.internet import defer
File "/usr/lib/python3.11/site-packages/twisted/internet/defer.py", line 14, in <module>
from asyncio import AbstractEventLoop, Future, iscoroutine
ModuleNotFoundError: No module named 'asyncio'

Signed-off-by: Hains van den Bosch <hainsvdbosch@ziggo.nl>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Guðni Már Gilbert April 4, 2024, 7:17 p.m. UTC | #1
Hi please ignore this patch/email from me, there is 1 more patch which is supposed to follow this one and I see it's not properly signed by me. I'll try sending this to myself first to check the email is sent correctly next time (I haven't done backporting before like this)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb b/meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb
index 3225b6c98..c55c86ea5 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb
@@ -57,6 +57,7 @@  RDEPENDS:${PN} = "\
 "
 
 RDEPENDS:${PN}-core = "${PYTHON_PN}-appdirs \
+                       ${PYTHON_PN}-asyncio \
                        ${PYTHON_PN}-automat \
                        ${PYTHON_PN}-constantly \
                        ${PYTHON_PN}-core \