diff mbox series

[meta-oe,2/2] highway,libjxl: Remove -mfp16-format=ieee when using clang compiler

Message ID 20240403212553.3543144-2-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/2] python3-pydbus: Add bash dependency for ptests | expand

Commit Message

Khem Raj April 3, 2024, 9:25 p.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-extended/highway/highway_1.1.0.bb  | 2 ++
 meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb | 3 ++-
 2 files changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/highway/highway_1.1.0.bb b/meta-oe/recipes-extended/highway/highway_1.1.0.bb
index ec9d8f742d..11d9e7cddf 100644
--- a/meta-oe/recipes-extended/highway/highway_1.1.0.bb
+++ b/meta-oe/recipes-extended/highway/highway_1.1.0.bb
@@ -13,3 +13,5 @@  S = "${WORKDIR}/git"
 
 EXTRA_OECMAKE = "-DBUILD_TESTING=0 -DCMAKE_BUILD_TYPE=Release"
 CXXFLAGS:append:arm = " -mfp16-format=ieee"
+# Option not supported with clang and its default format for __fp16 anyway with clang
+CXXFLAGS:remove:toolchain-clang = "-mfp16-format=ieee"
diff --git a/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb b/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb
index 0c4f79fdb4..142b283614 100644
--- a/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb
+++ b/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb
@@ -39,4 +39,5 @@  PACKAGECONFIG[mime] = "-DJPEGXL_ENABLE_PLUGIN_MIME=ON,-DJPEGXL_ENABLE_PLUGIN_MIM
 FILES:${PN} += "${libdir}/gdk-pixbuf-2.0 ${datadir}"
 
 CXXFLAGS:append:arm = " -mfp16-format=ieee"
-
+# Option not supported with clang and its default format for __fp16 anyway with clang
+CXXFLAGS:remove:toolchain-clang = "-mfp16-format=ieee"