Patchwork [01/15] pkg-config: replace obsolete automake macros with working ones

login
register
mail settings
Submitter Marko Lindqvist
Date Jan. 3, 2013, 8:36 p.m.
Message ID <1357245391-11055-2-git-send-email-cazfi74@gmail.com>
Download mbox | patch
Permalink /patch/41945/
State New
Headers show

Comments

Marko Lindqvist - Jan. 3, 2013, 8:36 p.m.
Add obsolete-automake-macros.patch that replaces automake macros
no longer supported by automake-1.13 with modern constructs.

Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
---
 .../pkgconfig-0.25/obsolete_automake_macros.patch  |   35 ++++++++++++++++++++
 meta/recipes-devtools/pkgconfig/pkgconfig.inc      |    4 ++-
 meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb  |    2 +-
 3 files changed, 39 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-devtools/pkgconfig/pkgconfig-0.25/obsolete_automake_macros.patch

Patch

diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig-0.25/obsolete_automake_macros.patch b/meta/recipes-devtools/pkgconfig/pkgconfig-0.25/obsolete_automake_macros.patch
new file mode 100644
index 0000000..d0a7e0f
--- /dev/null
+++ b/meta/recipes-devtools/pkgconfig/pkgconfig-0.25/obsolete_automake_macros.patch
@@ -0,0 +1,35 @@ 
+Upstream-status: Fixed
+
+Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
+diff -Nurd pkg-config-0.25/configure.in pkg-config-0.25/configure.in
+--- pkg-config-0.25/configure.in	2010-05-28 18:55:09.000000000 +0300
++++ pkg-config-0.25/configure.in	2013-01-01 22:13:47.009573426 +0200
+@@ -4,7 +4,7 @@
+ AM_INIT_AUTOMAKE(pkg-config, 0.25)
+ AM_MAINTAINER_MODE
+
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ AM_PROG_LIBTOOL
+
+diff -Nurd pkg-config-0.25/glib-1.2.10/configure.in pkg-config-0.25/glib-1.2.10/configure.in
+--- pkg-config-0.25/glib-1.2.10/configure.in	2009-12-06 22:43:59.000000000 +0200
++++ pkg-config-0.25/glib-1.2.10/configure.in	2013-01-01 22:23:36.701560486 +0200
+@@ -63,7 +63,7 @@
+ AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
+
+ # Specify a configuration file
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ AC_DEFINE_UNQUOTED(GLIB_MAJOR_VERSION, $GLIB_MAJOR_VERSION)
+ AC_DEFINE_UNQUOTED(GLIB_MINOR_VERSION, $GLIB_MINOR_VERSION)
+@@ -154,7 +154,6 @@
+
+ # Checks for programs.
+ AC_PROG_CC
+-AM_PROG_CC_STDC
+ AC_PROG_INSTALL
+
+ changequote(,)dnl
diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig.inc b/meta/recipes-devtools/pkgconfig/pkgconfig.inc
index c54e325..a2d4700 100644
--- a/meta/recipes-devtools/pkgconfig/pkgconfig.inc
+++ b/meta/recipes-devtools/pkgconfig/pkgconfig.inc
@@ -15,7 +15,9 @@  DEPENDS_class-nativesdk = ""
 SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \
            file://autofoo.patch \
            file://glibconfig-sysdefs.h \
-           file://disable-legacy.patch"
+           file://disable-legacy.patch \
+           file://obsolete_automake_macros.patch \
+"
 
 S = "${WORKDIR}/pkg-config-${PV}/"
 
diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb b/meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb
index d0a2b1f..a269973 100644
--- a/meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb
+++ b/meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb
@@ -1,6 +1,6 @@ 
 require pkgconfig.inc
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI[md5sum] = "a3270bab3f4b69b7dc6dbdacbcae9745"
 SRC_URI[sha256sum] = "3ba691ee2431f32ccb8efa131e59bf23e37f122dc66791309023ca6dcefcd10e"