[meta-python,1/2] python3-cmd2: Upgrade 2.3.3 -> 2.4.0

Message ID 20220223234533.1829801-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/2] python3-cmd2: Upgrade 2.3.3 -> 2.4.0 | expand

Commit Message

Leon Anavi Feb. 23, 2022, 11:45 p.m. UTC
Upgrade to release 2.4.0:

- Fixed issue where tab completion was quoting argparse flags in
  some cases.
- Added broader exception handling when enabling clipboard
  functionality via pyperclip.
- Added PassThroughException to __init__.py imports.
- cmd2 now uses pyreadline3 when running any version of Python
  on Windows
- Improved memory usage in certain use cases of tables
  (e.g. nested colored tables)
- Deleted cmd2.fg and cmd2.bg which were deprecated in 2.3.0.
  Use cmd2.Fg and cmd2.Bg instead.

License-Update: Update years

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/{python3-cmd2_2.3.3.bb => python3-cmd2_2.4.0.bb}   | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-cmd2_2.3.3.bb => python3-cmd2_2.4.0.bb} (74%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-cmd2_2.3.3.bb b/meta-python/recipes-devtools/python/python3-cmd2_2.4.0.bb
similarity index 74%
rename from meta-python/recipes-devtools/python/python3-cmd2_2.3.3.bb
rename to meta-python/recipes-devtools/python/python3-cmd2_2.4.0.bb
index d8a4fb5f2..bc3fedd37 100644
--- a/meta-python/recipes-devtools/python/python3-cmd2_2.3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-cmd2_2.4.0.bb
@@ -1,11 +1,11 @@ 
 SUMMARY = "Extra features for standard library's cmd module"
 HOMEPAGE = "https://github.com/python-cmd2/cmd2"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4c527bcb481233ebcb803de975f42701"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=209e288518b0668115f58c3929af9ff1"
 
 DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
 
-SRC_URI[sha256sum] = "750d7eb04d55c3bc2a413e191bc177856f388102de47d11f2210a35266543640"
+SRC_URI[sha256sum] = "090909ab6c8ecee40813cec759e61dd6e70c8227a1a8e96082f5f2b0d394bc77"
 
 inherit pypi setuptools3