diff mbox series

[meta-python] meta-python-image-ptest: Use 2G RAM for some demanding tests

Message ID 20240331153148.324399-1-raj.khem@gmail.com
State New
Headers show
Series [meta-python] meta-python-image-ptest: Use 2G RAM for some demanding tests | expand

Commit Message

Khem Raj March 31, 2024, 3:31 p.m. UTC
scrypt/fastjsonschema/pillow run into OOM on some qemu
architectures e.g. RISCV64. Raise the memory to be atleast 2G
for running these ptest images

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-python/recipes-core/images/meta-python-image-ptest.bb | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-core/images/meta-python-image-ptest.bb b/meta-python/recipes-core/images/meta-python-image-ptest.bb
index 9c542855a2..002bd7a39e 100644
--- a/meta-python/recipes-core/images/meta-python-image-ptest.bb
+++ b/meta-python/recipes-core/images/meta-python-image-ptest.bb
@@ -27,6 +27,10 @@  IMAGE_ROOTFS_EXTRA_SPACE = "324288"
 QB_MEM = "-m 1024"
 # If a particular ptest needs more memory, it can be customized:
 #QB_MEM:virtclass-mcextend-<pn> = "-m 4096"
+# python3-scrypt ptests run into OOMs on RISCV64 qemu
+QB_MEM:virtclass-mcextend-python3-scrypt = "-m 2048"
+QB_MEM:virtclass-mcextend-python3-fastjsonschema = "-m 2048"
+QB_MEM:virtclass-mcextend-python3-pillow = "-m 2048"
 
 TEST_SUITES = "ping ssh parselogs ptest"