diff mbox series

[meta-python] python3-validators: upgrade 0.22.0 > 0.24.0 and enable ptest

Message ID 20240330053056.77274-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-validators: upgrade 0.22.0 > 0.24.0 and enable ptest | expand

Commit Message

Alper Ak March 30, 2024, 5:30 a.m. UTC
License-Update: Rename LICENSE to LICENSE.txt and update copyright year

* Ptest and library example tested on qemux86-64 and qemuarm64

* Add ptest into PTESTS_FAST_META_PYTHON

qemux86-64:

Testsuite summary
TOTAL: 599
PASS: 599
SKIP: 0
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 19
END: /usr/lib/python3-validators/ptest
2024-03-30T05:07
STOP: ptest-runner
TOTAL: 1 FAIL: 0

qemuarm64:

Testsuite summary
TOTAL: 599
PASS: 599
SKIP: 0
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 18
END: /usr/lib/python3-validators/ptest
2024-03-30T05:10
STOP: ptest-runner
TOTAL: 1 FAIL: 0

Changelog:

0.24.0
===========
Features

    feat: conditionally raises ValidationError; bump version by @yozachar in #343

Maintenance

    patch: domain & url modules by @yozachar in #339
    fix: domain name not confirming to rfc_2782 by @yozachar in #341
    maint: update dev dependencies; adds favicon to docs by @yozachar in #342

0.23.2
===========
Maintenance

    maint: rectifies changelog by @yozachar in #336
    fix: packaging as well as rST & md document generation by @yozachar in #337

0.23.1
===========
Maintenance

    maint: fix between & length validators by @yozachar in #334
    fix: manual nav reference for mkdocs; bumps version by @yozachar in #335

0.23.0
===========
Features

    feat: add french i18n validation by @imperosol in #308

Maintenance

    fix: Valid URLs failing validation - query and fragment parts by @danherbriley in #297
    fix: bug in between module by @yozachar in #301
    chore: update dependencies, improve packaging by @yozachar in #304
    Fix fragment check by @darkdragon-001 in #305
    build(deps): bump urllib3 from 2.0.6 to 2.0.7 in /package by @dependabot in #310
    fix: allow pct-encoded entities in fragments by @conitrade-as in #317
    chore: update dev dependencies by @yozachar in #318
    build(deps): bump gitpython from 3.1.37 to 3.1.41 in /package by @dependabot in #321
    build(deps): bump jinja2 from 3.1.2 to 3.1.3 in /package by @dependabot in #322
    chore: monthly updates for Jan'24 by @yozachar in #324
    maint: adds versiond docs; update copyright year by @yozachar in #329
    chore: update dev dependencies by @yozachar in #330
    build(deps): bump gitpython from 3.1.37 to 3.1.41 in /package by @dependabot in #331
    build(deps): bump jinja2 from 3.1.2 to 3.1.3 in /package by @dependabot in #332
    build(deps): bump urllib3 from 2.0.6 to 2.0.7 in /package by @dependabot in #319

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../ptest-packagelists-meta-python.inc        |  1 +
 .../python/python3-validators/run-ptest       |  3 +++
 ...0.22.0.bb => python3-validators_0.24.0.bb} | 26 ++++++++++++++++---
 3 files changed, 27 insertions(+), 3 deletions(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-validators/run-ptest
 rename meta-python/recipes-devtools/python/{python3-validators_0.22.0.bb => python3-validators_0.24.0.bb} (23%)
diff mbox series

Patch

diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index ccb443182..2f7babe48 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -73,6 +73,7 @@  PTESTS_FAST_META_PYTHON = "\
     python3-u-msgpack-python \
     python3-unidiff \
     python3-uritemplate \
+    python3-validators \
     python3-wrapt \
     python3-wsproto \
     python3-xlrd \
diff --git a/meta-python/recipes-devtools/python/python3-validators/run-ptest b/meta-python/recipes-devtools/python/python3-validators/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-validators/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-validators_0.22.0.bb b/meta-python/recipes-devtools/python/python3-validators_0.24.0.bb
similarity index 23%
rename from meta-python/recipes-devtools/python/python3-validators_0.22.0.bb
rename to meta-python/recipes-devtools/python/python3-validators_0.24.0.bb
index 1da7ee4a0..78261dd67 100644
--- a/meta-python/recipes-devtools/python/python3-validators_0.22.0.bb
+++ b/meta-python/recipes-devtools/python/python3-validators_0.24.0.bb
@@ -2,9 +2,29 @@  SUMMARY = "Python Data Validation for Humans"
 HOMEPAGE = "https://python-validators.github.io/validators"
 LICENSE = "MIT"
 
-LIC_FILES_CHKSUM = "file://LICENSE;md5=fcf28bd09a60e145c3171c531b9e677d"
-SRC_URI[sha256sum] = "77b2689b172eeeb600d9605ab86194641670cdb73b60afd577142a9397873370"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b3fb4b9e6db86c69a33d5e3ee013ab59"
+SRC_URI[sha256sum] = "cd23defb36de42d14e7559cf0757f761bb46b10d9de2998e6ef805f769d859e3"
 
-inherit pypi python_setuptools_build_meta
+inherit pypi python_setuptools_build_meta ptest
+
+SRC_URI += " \
+	file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+	python3-pytest \
+	python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+	install -d ${D}${PTEST_PATH}/tests
+	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS:${PN} += " \
+	python3-crypt \
+	python3-datetime \
+	python3-netclient \
+"
 
 BBCLASSEXTEND = "native nativesdk"