diff mbox series

[v2] gmp: improve reproducibility

Message ID 20240327171616.950846-1-omatiush@cisco.com
State New
Headers show
Series [v2] gmp: improve reproducibility | expand

Commit Message

nativesdk-gmp package contains host references in output packages.
remove them.

Signed-off-by: Oleh Matiusha <omatiush@cisco.com>
---
v2
 - move common code to separate function
---
---
 meta/recipes-support/gmp/gmp_6.3.0.bb | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

Comments

Khem Raj March 27, 2024, 6:24 p.m. UTC | #1
On Wed, Mar 27, 2024 at 10:16 AM Oleh Matiusha via
lists.openembedded.org <omatiush=cisco.com@lists.openembedded.org>
wrote:
>
> nativesdk-gmp package contains host references in output packages.
> remove them.
>
> Signed-off-by: Oleh Matiusha <omatiush@cisco.com>
> ---
> v2
>  - move common code to separate function
> ---
> ---
>  meta/recipes-support/gmp/gmp_6.3.0.bb | 10 +++++++++-
>  1 file changed, 9 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-support/gmp/gmp_6.3.0.bb b/meta/recipes-support/gmp/gmp_6.3.0.bb
> index 3dbcd68b5c..fd4aec92fd 100644
> --- a/meta/recipes-support/gmp/gmp_6.3.0.bb
> +++ b/meta/recipes-support/gmp/gmp_6.3.0.bb
> @@ -29,13 +29,21 @@ do_install:append() {
>         oe_multilib_header gmp.h
>  }
>
> -do_install:prepend:class-target() {
> +fix_absolute_paths () {
>          sed -i \
>          -e "s|--sysroot=${STAGING_DIR_HOST}||g" \
>          -e "s|${DEBUG_PREFIX_MAP}||g" \
>           ${B}/gmp.h
>  }
>
> +do_install:prepend:class-target() {
> +    fix_absolute_paths
> +}
> +
> +do_install:prepend:class-nativesdk() {
> +    fix_absolute_paths
> +}
> +

why can't we have it in common do_install shared across all
variants of recipes.

>  SSTATE_SCAN_FILES += "gmp.h"
>
>  # Doesn't compile in MIPS16e mode due to use of hand-written
> --
> 2.33.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#197565): https://lists.openembedded.org/g/openembedded-core/message/197565
> Mute This Topic: https://lists.openembedded.org/mt/105181617/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-support/gmp/gmp_6.3.0.bb b/meta/recipes-support/gmp/gmp_6.3.0.bb
index 3dbcd68b5c..fd4aec92fd 100644
--- a/meta/recipes-support/gmp/gmp_6.3.0.bb
+++ b/meta/recipes-support/gmp/gmp_6.3.0.bb
@@ -29,13 +29,21 @@  do_install:append() {
 	oe_multilib_header gmp.h
 }
 
-do_install:prepend:class-target() {
+fix_absolute_paths () {
         sed -i \
         -e "s|--sysroot=${STAGING_DIR_HOST}||g" \
         -e "s|${DEBUG_PREFIX_MAP}||g" \
          ${B}/gmp.h
 }
 
+do_install:prepend:class-target() {
+    fix_absolute_paths
+}
+
+do_install:prepend:class-nativesdk() {
+    fix_absolute_paths
+}
+
 SSTATE_SCAN_FILES += "gmp.h"
 
 # Doesn't compile in MIPS16e mode due to use of hand-written