diff mbox series

[2/3] autoconf: Add missing perl modules to RDEPENDS

Message ID 20240322101053.1397030-2-Harish.Sadineni@windriver.com
State Accepted, archived
Commit 71a751fd561c9087ef027dd4985b80bd27090421
Headers show
Series [1/3] nativesdk-packagegroup-sdk-host: add gprofng package to RDEPENDS | expand

Commit Message

Sadineni, Harish March 22, 2024, 10:10 a.m. UTC
From: Harish Sadineni <Harish.Sadineni@windriver.com>

In SDK, missing perl modules causes 'x86_64-wrlinuxsdk-linux-gp-display-html --help' to abort with below errors..
 - Can't locate bignum.pm in @INC (you may need to install the feature module).
 - Can't locate Math/BigInt.pm in @INC (you may need to install the Math::BigInt module)

Signed-off-by: Harish Sadineni <Harish.Sadineni@windriver.com>
---
 meta/recipes-devtools/autoconf/autoconf_2.72e.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Richard Purdie March 22, 2024, 10:30 p.m. UTC | #1
On Fri, 2024-03-22 at 03:10 -0700, Sadineni, Harish via
lists.openembedded.org wrote:
> From: Harish Sadineni <Harish.Sadineni@windriver.com>
> 
> In SDK, missing perl modules causes 'x86_64-wrlinuxsdk-linux-gp-
> display-html --help' to abort with below errors..
>  - Can't locate bignum.pm in @INC (you may need to install the
> feature module).
>  - Can't locate Math/BigInt.pm in @INC (you may need to install the
> Math::BigInt module)
> 
> Signed-off-by: Harish Sadineni <Harish.Sadineni@windriver.com>
> ---
>  meta/recipes-devtools/autoconf/autoconf_2.72e.bb | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
> b/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
> index db374373cf..2a459b7cb6 100644
> --- a/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
> +++ b/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
> @@ -52,6 +52,9 @@ RDEPENDS:${PN} = "m4 gnu-config \
>  		  perl-module-thread-queue \
>  		  perl-module-threads \
>  		  perl-module-feature \
> +                  perl-module-bignum \
> +                  perl-module-bigint \
> +                  perl-module-math-bigint \
>  		 "
>  RDEPENDS:${PN}:class-native = "m4-native gnu-config-native hostperl-
> runtime-native"
>  

Was this dependency missing from autoconf or was it from some tools in
binutils? If the latter, we should be adding the missing dependency to
the specific package.

Cheers,

Richard
Sadineni, Harish March 29, 2024, 3:10 p.m. UTC | #2
This dependency is from autoconf itself, not from binutils.

Thanks,
Harish sadineni
diff mbox series

Patch

diff --git a/meta/recipes-devtools/autoconf/autoconf_2.72e.bb b/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
index db374373cf..2a459b7cb6 100644
--- a/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
+++ b/meta/recipes-devtools/autoconf/autoconf_2.72e.bb
@@ -52,6 +52,9 @@  RDEPENDS:${PN} = "m4 gnu-config \
 		  perl-module-thread-queue \
 		  perl-module-threads \
 		  perl-module-feature \
+                  perl-module-bignum \
+                  perl-module-bigint \
+                  perl-module-math-bigint \
 		 "
 RDEPENDS:${PN}:class-native = "m4-native gnu-config-native hostperl-runtime-native"