diff mbox series

[1/1] linux-firmware : Add firmaware for Intel 9260 wifi modules.

Message ID 20240313153922.154396-1-y.rodriguez@i2s.fr
State New
Headers show
Series [1/1] linux-firmware : Add firmaware for Intel 9260 wifi modules. | expand

Commit Message

Yannick Rodriguez March 13, 2024, 3:39 p.m. UTC
From: Yannick Rodriguez <y.rodriguez@i2s.fr>


Intel 9260 wifi modules  is a serie of wireless modules that need firmwares to function correctly. The linux firmware recipe does not have a package of these firmwares, and this commit add them.

Signed-off-by: Yannick Rodriguez <y.rodriguez@i2s.fr>
---
 meta/recipes-kernel/linux-firmware/linux-firmware_20240220.bb | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Quentin Schulz March 13, 2024, 4:04 p.m. UTC | #1
Hi Yannick,

Thanks for the patch.

Typo in the commit title: firmware and not firmaware.

Also, to be pedantic, you're not adding firmware for Intel 9260 modules, 
you're moving the different pieces of firmware to a separate package.

On 3/13/24 16:39, Yannick Rodriguez via lists.openembedded.org wrote:
> [You don't often get email from yannickrodriguez22=gmail.com@lists.openembedded.org. Learn why this is important at https://aka.ms/LearnAboutSenderIdentification ]
> 
> From: Yannick Rodriguez <y.rodriguez@i2s.fr>
> 
> 
> Intel 9260 wifi modules  is a serie of wireless modules that need firmwares to function correctly. The linux firmware recipe does not have a package of these firmwares, and this commit add them.
> 

Just to be pedantic, but linux-firmware has a package for it, it's just 
happen to be a package where all the files that didn't match make it. 
Which means it's several dozens of MB big, which isn't really nice :)

Also the commit log is usually wrapped at 72 characters, but I cannot 
find where we put this in the contributor guide... if we even did put it 
there.

Since this 9260 is a combo chip with both Bluetooth and WiFi, what about 
adding a separate package for the bluetooth part as well?

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?h=20220610&id=97339b3a1d3bf3e4c40d679896a27a25fa83765f

seems to indicate that we can have a
${PN}-ibt-18 package with all firmware/intel/ibt-18-*.ddc and 
firmware/intel/ibt-18-*.sfi?

Looks good otherwise,
Cheers,
Quentin
Quentin Schulz March 13, 2024, 4:36 p.m. UTC | #2
Hi Yannick,

On 3/13/24 17:29, RODRIGUEZ Yannick wrote:
> Hi Quentin,
> 
> Thanks for your review.
> 
> Should i resend a patch with the modification your sugest . It's possible to just amend m'y patch ?
> 

For the bluetooth part of the suggestion, a separate patch would be 
welcome. Though it's a suggestion, just a "would be nice to have", 
you're not required per-se to do it for the wifi part to be merged (at 
least that's my opinion as a contributor).

I think it'd be good to send a new version of the patch with the small 
changes in the wording in the commit title and commit log, so you don't 
have to wait for the maintainers to confirm this is a required change.

Don't forget to add the v2 (well it's now v3 technically ;) ) to the 
patch, c.f. 
https://docs.yoctoproject.org/contributor-guide/submit-changes.html#taking-patch-review-into-account 
for how to do it.

> It's m'y first patch.
> 

Congratulations :) Wishing you (and us) many more to come!

https://docs.yoctoproject.org/contributor-guide/index.html should help 
you get started. If something isn't clear there (or wrong, or 
misleading, or outdated, etc...), let us know (or send a patch for the 
documentation :) ).

Cheers,
Quentin
Yannick Rodriguez March 13, 2024, 8:23 p.m. UTC | #3
Hi Quentin ,

Thanks for your help , i'll push v2 then.

Regards

Yannick

On 13/03/2024 17:36, Quentin Schulz wrote:
> Hi Yannick,
>
> On 3/13/24 17:29, RODRIGUEZ Yannick wrote:
>> Hi Quentin,
>>
>> Thanks for your review.
>>
>> Should i resend a patch with the modification your sugest . It's 
>> possible to just amend m'y patch ?
>>
>
> For the bluetooth part of the suggestion, a separate patch would be 
> welcome. Though it's a suggestion, just a "would be nice to have", 
> you're not required per-se to do it for the wifi part to be merged (at 
> least that's my opinion as a contributor).
>
> I think it'd be good to send a new version of the patch with the small 
> changes in the wording in the commit title and commit log, so you 
> don't have to wait for the maintainers to confirm this is a required 
> change.
>
> Don't forget to add the v2 (well it's now v3 technically ;) ) to the 
> patch, c.f. 
> https://docs.yoctoproject.org/contributor-guide/submit-changes.html#taking-patch-review-into-account 
> for how to do it.
>
>> It's m'y first patch.
>>
>
> Congratulations :) Wishing you (and us) many more to come!
>
> https://docs.yoctoproject.org/contributor-guide/index.html should help 
> you get started. If something isn't clear there (or wrong, or 
> misleading, or outdated, etc...), let us know (or send a patch for the 
> documentation :) ).
>
> Cheers,
> Quentin
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux-firmware/linux-firmware_20240220.bb b/meta/recipes-kernel/linux-firmware/linux-firmware_20240220.bb
index 1fd44f4d53..e7d9526b3e 100644
--- a/meta/recipes-kernel/linux-firmware/linux-firmware_20240220.bb
+++ b/meta/recipes-kernel/linux-firmware/linux-firmware_20240220.bb
@@ -336,6 +336,7 @@  PACKAGES =+ "${PN}-amphion-vpu-license ${PN}-amphion-vpu \
              ${PN}-iwlwifi-7265 \
              ${PN}-iwlwifi-7265d ${PN}-iwlwifi-8000c ${PN}-iwlwifi-8265 \
              ${PN}-iwlwifi-9000 \
+             ${PN}-iwlwifi-9260 \
              ${PN}-iwlwifi-misc \
              ${PN}-ibt-license ${PN}-ibt \
              ${PN}-ibt-11-5 ${PN}-ibt-12-16 ${PN}-ibt-hw-37-7 ${PN}-ibt-hw-37-8 \
@@ -1190,6 +1191,7 @@  LICENSE:${PN}-iwlwifi-7265d     = "Firmware-iwlwifi_firmware"
 LICENSE:${PN}-iwlwifi-8000c     = "Firmware-iwlwifi_firmware"
 LICENSE:${PN}-iwlwifi-8265      = "Firmware-iwlwifi_firmware"
 LICENSE:${PN}-iwlwifi-9000      = "Firmware-iwlwifi_firmware"
+LICENSE:${PN}-iwlwifi-9260      = "Firmware-iwlwifi_firmware"
 LICENSE:${PN}-iwlwifi-misc      = "Firmware-iwlwifi_firmware"
 LICENSE:${PN}-iwlwifi-license   = "Firmware-iwlwifi_firmware"
 
@@ -1217,6 +1219,7 @@  FILES:${PN}-iwlwifi-7265d   = "${nonarch_base_libdir}/firmware/iwlwifi-7265D-*.u
 FILES:${PN}-iwlwifi-8000c   = "${nonarch_base_libdir}/firmware/iwlwifi-8000C-*.ucode"
 FILES:${PN}-iwlwifi-8265   = "${nonarch_base_libdir}/firmware/iwlwifi-8265-*.ucode"
 FILES:${PN}-iwlwifi-9000   = "${nonarch_base_libdir}/firmware/iwlwifi-9000-*.ucode"
+FILES:${PN}-iwlwifi-9260   = "${nonarch_base_libdir}/firmware/iwlwifi-9260-*.ucode"
 FILES:${PN}-iwlwifi-misc   = " \
     ${nonarch_base_libdir}/firmware/iwlwifi-*.ucode \
     ${nonarch_base_libdir}/firmware/iwlwifi-*.pnvm \
@@ -1244,6 +1247,7 @@  RDEPENDS:${PN}-iwlwifi-7265d     = "${PN}-iwlwifi-license"
 RDEPENDS:${PN}-iwlwifi-8000c     = "${PN}-iwlwifi-license"
 RDEPENDS:${PN}-iwlwifi-8265      = "${PN}-iwlwifi-license"
 RDEPENDS:${PN}-iwlwifi-9000      = "${PN}-iwlwifi-license"
+RDEPENDS:${PN}-iwlwifi-9260      = "${PN}-iwlwifi-license"
 RDEPENDS:${PN}-iwlwifi-misc      = "${PN}-iwlwifi-license"
 
 # -iwlwifi-misc is a "catch all" package that includes all the iwlwifi