Patchwork [meta-oe,6/7] florence: added gnome-doc-utils and libnotify to dependencies

login
register
mail settings
Submitter Marcin Juszkiewicz
Date Dec. 13, 2012, 10:35 a.m.
Message ID <1355394929-25182-7-git-send-email-marcin.juszkiewicz@linaro.org>
Download mbox | patch
Permalink /patch/40889/
State Accepted, archived
Commit b7ecd9099b118379245fca6316705c12e4aa02ed
Headers show

Comments

Marcin Juszkiewicz - Dec. 13, 2012, 10:35 a.m.
gnome-doc-utils due to this:

| autoreconf: Entering directory `.'
| autoreconf: configure.ac: not using Gettext
| autoreconf: running: aclocal --system-acdir=/home/hrw/HDD/devel/canonical/aarch64/CLEAN/build/tmp-eglibc/work/aarch64-oe-linux/florence/0.5.1-r1/florence-0.5.1/aclocal-copy/ --automake-acdir=/home/hrw/HDD/devel/canonical/aarch64/CLEAN/build/tmp-eglibc/sysroots/x86_64-linux/usr/share/aclocal-1.12 --force
| autoreconf: configure.ac: tracing
| autoreconf: configure.ac: not using Libtool
| autoreconf: running: /home/hrw/HDD/devel/canonical/aarch64/CLEAN/build/tmp-eglibc/sysroots/x86_64-linux/usr/bin/autoconf --force
| autoreconf: running: /home/hrw/HDD/devel/canonical/aarch64/CLEAN/build/tmp-eglibc/sysroots/x86_64-linux/usr/bin/autoheader --force
| autoreconf: running: automake --foreign --add-missing --copy --force-missing
| gnome-doc-utils.make:63: error: HAVE_GNOME_DOC_UTILS does not appear in AM_CONDITIONAL
| docs/Makefile.am:1:   'gnome-doc-utils.make' included from here
| gnome-doc-utils.make:143: error: ENABLE_SK does not appear in AM_CONDITIONAL
| docs/Makefile.am:1:   'gnome-doc-utils.make' included from here
| gnome-doc-utils.make:192: error: ENABLE_SK does not appear in AM_CONDITIONAL
| docs/Makefile.am:1:   'gnome-doc-utils.make' included from here
| src/Makefile.am:6: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
| autoreconf: automake failed with exit status: 1
| ERROR: autoreconf execution failed.

libnotify due to:

| configure:7503: checking for LIBNOTIFY
| configure:7510: $PKG_CONFIG --exists --print-errors "libnotify"
| Package libnotify was not found in the pkg-config search path.
| Perhaps you should add the directory containing `libnotify.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'libnotify' found

Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
---
 meta-oe/recipes-support/florence/florence_0.5.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta-oe/recipes-support/florence/florence_0.5.1.bb b/meta-oe/recipes-support/florence/florence_0.5.1.bb
index dcbcefa..56d8914 100644
--- a/meta-oe/recipes-support/florence/florence_0.5.1.bb
+++ b/meta-oe/recipes-support/florence/florence_0.5.1.bb
@@ -8,7 +8,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
 
 PR = "r1"
 
-DEPENDS = "gtk+ libxml2 libglade librsvg libxtst gconf cairo intltool-native"
+DEPENDS = "gtk+ libxml2 libglade librsvg libxtst gconf cairo intltool-native gnome-doc-utils libnotify"
 
 SRC_URI = "http://switch.dl.sourceforge.net/project/florence/florence/0.5.1/florence-0.5.1.tar.bz2 \
            file://0001-Fix-glib-includes.patch"