diff mbox series

[meta-ti,master,1/5] recipes-bsp: Do not use MACHINE_ARCH when package is not machine specific

Message ID 20240312154243.17627-1-afd@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,master,1/5] recipes-bsp: Do not use MACHINE_ARCH when package is not machine specific | expand

Commit Message

Andrew Davis March 12, 2024, 3:42 p.m. UTC
Most firmware does not run on the host and is therefor not architecture
specific, at least as far as the package manager is concerned. Although
the firmware might not be useful on some machines, the package itself
is not machine specific. Remove PACKAGE_ARCH.

Signed-off-by: Andrew Davis <afd@ti.com>
---
 meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb | 2 --
 meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb         | 2 --
 meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb     | 1 -
 meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb             | 2 --
 meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb   | 2 --
 meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb       | 2 --
 meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb   | 2 --
 meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb     | 2 --
 meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb | 2 --
 meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb              | 1 -
 meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb           | 1 -
 11 files changed, 19 deletions(-)

Comments

Chirag Shilwant March 13, 2024, 6:17 a.m. UTC | #1
On 12/03/24 21:12, Andrew Davis via lists.yoctoproject.org wrote:
> Most firmware does not run on the host and is therefor not 
> architecture specific, at least as far as the package manager is 
> concerned. Although the firmware might not be useful on some machines, 
> the package itself is not machine specific. Remove
> ZjQcmQRYFpfptBannerStart
> This message was sent from outside of Texas Instruments.
> Do not click links or open attachments unless you recognize the source 
> of this email and know the content is safe.
> ZjQcmQRYFpfptBannerEnd
> Most firmware does not run on the host and is therefor not architecture
s/therefor/therefore
> specific, at least as far as the package manager is concerned. Although
> the firmware might not be useful on some machines, the package itself
> is not machine specific. Remove PACKAGE_ARCH.
>
> Signed-off-by: Andrew Davis <afd@ti.com>
> ---
>   meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb | 2 --
>   meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb         | 2 --
>   meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb     | 1 -
>   meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb             | 2 --
>   meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb   | 2 --
>   meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb       | 2 --
>   meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb   | 2 --
>   meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb     | 2 --
>   meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb | 2 --
>   meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb              | 1 -
>   meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb           | 1 -
>   11 files changed, 19 deletions(-)
>
> diff --git a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
> index d88bca6e..ed1c7817 100644
> --- a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
> +++ b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
> @@ -10,8 +10,6 @@ PR = "${INC_PR}.0"
>   
>   COMPATIBLE_MACHINE = "j721e|j721s2|j784s4"
>   
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
> -
>   TARGET = "mhdp8546.bin"
>   
>   do_install() {
> diff --git a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
> index d1b99979..1a2e911c 100644
> --- a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
> +++ b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
> @@ -12,8 +12,6 @@ PR = "${INC_PR}.1"
>   
>   COMPATIBLE_MACHINE = "j721s2|j784s4|j722s|am62axx|am62pxx"
>   
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
> -
>   TARGET_WAVE521C = "wave521c_codec_fw.bin"
>   
>   SOURCE_WAVE521C = "wave521c_k3_codec_fw.bin"
> diff --git a/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
> index 61b1b986..95ba1e2d 100755
> --- a/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
> +++ b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
> @@ -4,7 +4,6 @@ LICENSE = "TI-TFL"
>   LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=04ad0a015d4bb63c2b9e7b112debf3db"
>   
>   PV = "6.2+git"
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
>   
>   inherit update-alternatives
>   
> diff --git a/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb b/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
> index e58f2d58..ee3a94dc 100644
> --- a/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
> +++ b/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
> @@ -10,8 +10,6 @@ PR = "${INC_PR}.0"
>   
>   COMPATIBLE_MACHINE = "dra7xx"
>   
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
> -
>   ORIGIN = "DRA71x-RevA-GT9271_SpecDig_Config.bin"
>   TARGET = "goodix_9271_cfg.bin"
>   
> diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
> index 2c0736ed..4b6ef75d 100644
> --- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
> +++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
> @@ -7,8 +7,6 @@ PR = "${INC_PR}.0"
>   
>   COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
>   
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
> -
>   TARGET = " \
>       am65x-sr2-pru0-prueth-fw.elf \
>       am65x-sr2-pru1-prueth-fw.elf \
> diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
> index 8b15ab7f..20b2bfb9 100644
> --- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
> +++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
> @@ -7,8 +7,6 @@ PR = "${INC_PR}.0"
>   
>   COMPATIBLE_MACHINE = "am65xx"
>   
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
> -
>   TARGET = " \
>       am65x-pru0-prueth-fw.elf \
>       am65x-pru1-prueth-fw.elf \
> diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
> index ea39d73d..bc731094 100644
> --- a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
> +++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
> @@ -7,8 +7,6 @@ PR = "${INC_PR}.0"
>   
>   COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
>   
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
> -
>   TARGET = " \
>       am65x-sr2-pru0-pruhsr-fw.elf \
>       am65x-sr2-pru1-pruhsr-fw.elf \
> diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
> index 63c2d311..6e296e7c 100644
> --- a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
> +++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
> @@ -7,8 +7,6 @@ PR = "${INC_PR}.0"
>   
>   COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
>   
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
> -
>   TARGET = " \
>       am65x-sr2-pru0-prusw-fw.elf \
>       am65x-sr2-pru1-prusw-fw.elf \
> diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
> index d295a1c1..74729c16 100644
> --- a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
> +++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
> @@ -9,8 +9,6 @@ PR = "${INC_PR}.0"
>   
>   COMPATIBLE_MACHINE = "j721e"
>   
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
> -
>   TARGET = "pvdec_full_bin.fw"
>   
>   do_install() {
> diff --git a/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb b/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb
> index 7d16ae39..4ec09a70 100644
> --- a/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb
> +++ b/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb
> @@ -3,7 +3,6 @@ LICENSE = "TI-TSPA"
>   LIC_FILES_CHKSUM = "file://${S}/J6_VIS_DEMO_LINUX_BINARY_01.50.07.15-Manifest.html;md5=a59aa54b9470f555cf086b91dca0afa3"
>   
>   COMPATIBLE_MACHINE = "dra7xx"
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
>   
>   PR = "r1"
>   
> diff --git a/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb b/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
> index 2452d111..8af49577 100644
> --- a/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
> +++ b/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
> @@ -4,7 +4,6 @@ LICENSE = "TI-TSPA"
>   LIC_FILES_CHKSUM = "file://COPYING;md5=fd463c9500441ed91d07a0331baa635c"
>   
>   COMPATIBLE_MACHINE = "dra7xx"
> -PACKAGE_ARCH = "${MACHINE_ARCH}"
>   
>   SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/vpdma-fw/03-2012/exports/vpdma-fw_03-2012.tar.gz;protocol=http;name=dra7xx-evm"
>   SRC_URI[dra7xx-evm.md5sum] = "80176df1350c21d9efa90171789c546e"
> -- 
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#17516): https://urldefense.com/v3/__https://lists.yoctoproject.org/g/meta-ti/message/17516__;!!G3vK!SOWH7xa4sXTpNoXJeNKUQ88iApWOwwFwJtcOijUMYwpuP_T9_QszPWk8CoNoG_d9HQ2hWNbH6aUMkVuEet7_K6qiBRhQ$
> Mute This Topic: https://urldefense.com/v3/__https://lists.yoctoproject.org/mt/104886932/7030289__;!!G3vK!SOWH7xa4sXTpNoXJeNKUQ88iApWOwwFwJtcOijUMYwpuP_T9_QszPWk8CoNoG_d9HQ2hWNbH6aUMkVuEet7_KyWG9S8P$
> Group Owner: meta-ti+owner@lists.yoctoproject.org
> Unsubscribe: https://urldefense.com/v3/__https://lists.yoctoproject.org/g/meta-ti/unsub__;!!G3vK!SOWH7xa4sXTpNoXJeNKUQ88iApWOwwFwJtcOijUMYwpuP_T9_QszPWk8CoNoG_d9HQ2hWNbH6aUMkVuEet7_K5vyG5Av$  [c-shilwant@ti.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
index d88bca6e..ed1c7817 100644
--- a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
@@ -10,8 +10,6 @@  PR = "${INC_PR}.0"
 
 COMPATIBLE_MACHINE = "j721e|j721s2|j784s4"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
 TARGET = "mhdp8546.bin"
 
 do_install() {
diff --git a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
index d1b99979..1a2e911c 100644
--- a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -12,8 +12,6 @@  PR = "${INC_PR}.1"
 
 COMPATIBLE_MACHINE = "j721s2|j784s4|j722s|am62axx|am62pxx"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
 TARGET_WAVE521C = "wave521c_codec_fw.bin"
 
 SOURCE_WAVE521C = "wave521c_k3_codec_fw.bin"
diff --git a/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
index 61b1b986..95ba1e2d 100755
--- a/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
@@ -4,7 +4,6 @@  LICENSE = "TI-TFL"
 LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=04ad0a015d4bb63c2b9e7b112debf3db"
 
 PV = "6.2+git"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 inherit update-alternatives
 
diff --git a/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb b/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
index e58f2d58..ee3a94dc 100644
--- a/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
@@ -10,8 +10,6 @@  PR = "${INC_PR}.0"
 
 COMPATIBLE_MACHINE = "dra7xx"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
 ORIGIN = "DRA71x-RevA-GT9271_SpecDig_Config.bin"
 TARGET = "goodix_9271_cfg.bin"
 
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
index 2c0736ed..4b6ef75d 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
@@ -7,8 +7,6 @@  PR = "${INC_PR}.0"
 
 COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
 TARGET = " \
     am65x-sr2-pru0-prueth-fw.elf \
     am65x-sr2-pru1-prueth-fw.elf \
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
index 8b15ab7f..20b2bfb9 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
@@ -7,8 +7,6 @@  PR = "${INC_PR}.0"
 
 COMPATIBLE_MACHINE = "am65xx"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
 TARGET = " \
     am65x-pru0-prueth-fw.elf \
     am65x-pru1-prueth-fw.elf \
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
index ea39d73d..bc731094 100644
--- a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
@@ -7,8 +7,6 @@  PR = "${INC_PR}.0"
 
 COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
 TARGET = " \
     am65x-sr2-pru0-pruhsr-fw.elf \
     am65x-sr2-pru1-pruhsr-fw.elf \
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
index 63c2d311..6e296e7c 100644
--- a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
+++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
@@ -7,8 +7,6 @@  PR = "${INC_PR}.0"
 
 COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
 TARGET = " \
     am65x-sr2-pru0-prusw-fw.elf \
     am65x-sr2-pru1-prusw-fw.elf \
diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
index d295a1c1..74729c16 100644
--- a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -9,8 +9,6 @@  PR = "${INC_PR}.0"
 
 COMPATIBLE_MACHINE = "j721e"
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
 TARGET = "pvdec_full_bin.fw"
 
 do_install() {
diff --git a/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb b/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb
index 7d16ae39..4ec09a70 100644
--- a/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb
+++ b/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb
@@ -3,7 +3,6 @@  LICENSE = "TI-TSPA"
 LIC_FILES_CHKSUM = "file://${S}/J6_VIS_DEMO_LINUX_BINARY_01.50.07.15-Manifest.html;md5=a59aa54b9470f555cf086b91dca0afa3"
 
 COMPATIBLE_MACHINE = "dra7xx"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 PR = "r1"
 
diff --git a/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb b/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
index 2452d111..8af49577 100644
--- a/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
+++ b/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
@@ -4,7 +4,6 @@  LICENSE = "TI-TSPA"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fd463c9500441ed91d07a0331baa635c"
 
 COMPATIBLE_MACHINE = "dra7xx"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/vpdma-fw/03-2012/exports/vpdma-fw_03-2012.tar.gz;protocol=http;name=dra7xx-evm"
 SRC_URI[dra7xx-evm.md5sum] = "80176df1350c21d9efa90171789c546e"