diff mbox series

[meta-oe] waylandpp: fix reproducibility issue

Message ID 20240310103839.1602112-1-f_l_k@t-online.de
State Accepted
Headers show
Series [meta-oe] waylandpp: fix reproducibility issue | expand

Commit Message

Markus Volk March 10, 2024, 10:38 a.m. UTC
remove STAGING_DIR_HOST and S from the waylandpp-targets.cmake file

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb b/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
index eb8ec4f5f..c1f5f4ed8 100644
--- a/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
+++ b/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
@@ -37,4 +37,9 @@  EXTRA_OECMAKE:class-target = " \
 	-DCMAKE_EXE_LINKER_FLAGS="-Wl,--enable-new-dtags" \
 "
 
+do_install:append:class-target() {
+    sed -i -e 's|${S}||g' ${D}${libdir}/cmake/waylandpp/waylandpp-targets.cmake
+    sed -i -e 's|${STAGING_DIR_HOST}||g' ${D}${libdir}/cmake/waylandpp/waylandpp-targets.cmake
+}
+
 BBCLASSEXTEND += "native nativesdk"