diff mbox series

[meta-gnome,4/5] gnome-terminal: fix reproducibility issue

Message ID 20240308190829.2442866-4-f_l_k@t-online.de
State Accepted
Headers show
Series [meta-gnome,1/5] gnome-control-center: fix reproducibility issue | expand

Commit Message

Markus Volk March 8, 2024, 7:08 p.m. UTC
gnome-terminal inserts lines containing ${S} into the source. Although required for
compilation, it affects reproducibility for the	src package.

Fix this by simply not packaging the modified source code

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb       | 2 ++
 1 file changed, 2 insertions(+)

Comments

Khem Raj March 9, 2024, 6:53 p.m. UTC | #1
On Fri, Mar 8, 2024 at 11:08 AM Markus Volk <f_l_k@t-online.de> wrote:
>
> gnome-terminal inserts lines containing ${S} into the source. Although required for
> compilation, it affects reproducibility for the src package.
>
> Fix this by simply not packaging the modified source code
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  .../recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb       | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb b/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb
> index 53f11e95f..3bbfe9ece 100644
> --- a/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb
> +++ b/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb
> @@ -31,6 +31,8 @@ PACKAGECONFIG ?= ""
>  PACKAGECONFIG[nautilus] = "-Dnautilus_extension=true,-Dnautilus_extension=false,nautilus,nautilus"
>  PACKAGECONFIG[search_provider] = "-Dsearch_provider=true -Ddbus_interface_dir=${STAGING_DATADIR}/dbus-1/interfaces,-Dsearch_provider=false,gnome-shell"
>
> +PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
> +

While this will fix the problem, it might degrade debugging
experience. I think it would be good to look into
the generated sources and see why they embed absolute filenames, often
the reason is that some tool
like lex or bison is used to generate them and it encodes them due to
how it is invoked especially in cross
compilation. This can then be fixed by correcting the call to lex or
invoking it in appropriate dir to avoid
absolute paths or use particular commandline options to eliminate the
absolute prefix.

>  FILES:${PN} += " \
>      ${datadir} \
>      ${libdir}/nautilus/extensions-4 \
> --
> 2.44.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109234): https://lists.openembedded.org/g/openembedded-devel/message/109234
> Mute This Topic: https://lists.openembedded.org/mt/104815316/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb b/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb
index 53f11e95f..3bbfe9ece 100644
--- a/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.50.1.bb
@@ -31,6 +31,8 @@  PACKAGECONFIG ?= ""
 PACKAGECONFIG[nautilus] = "-Dnautilus_extension=true,-Dnautilus_extension=false,nautilus,nautilus"
 PACKAGECONFIG[search_provider] = "-Dsearch_provider=true -Ddbus_interface_dir=${STAGING_DATADIR}/dbus-1/interfaces,-Dsearch_provider=false,gnome-shell"
 
+PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
+
 FILES:${PN} += " \
     ${datadir} \
     ${libdir}/nautilus/extensions-4 \