diff mbox series

[meta-python] python3-dateutil: upgrade 2.8.2 -> 2.9.0

Message ID 20240305111123.371640-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-dateutil: upgrade 2.8.2 -> 2.9.0 | expand

Commit Message

Alper Ak March 5, 2024, 11:11 a.m. UTC
Changelog:

Data updates

    Updated tzdata version to 2024a.

Features

    Made all dateutil submodules lazily imported using PEP 562. On Python 3.7+, things like import dateutil; dateutil.tz.gettz("America/New_York") will now work without explicitly importing dateutil.
	tz, with the import occurring behind the scenes on first use. The old behavior remains on Python 3.6 and earlier.

Bugfixes

    Removed a call to datetime.utcfromtimestamp, which is deprecated as of Python 3.12.

Documentation changes

    Added note into docs and tests where relativedelta would return last day of the month only if the same day on a different month resolves to a date that doesn't exist.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../{python3-dateutil_2.8.2.bb => python3-dateutil_2.9.0.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-dateutil_2.8.2.bb => python3-dateutil_2.9.0.bb} (89%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb
rename to meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
index c8e8a45c9..bcb68d771 100644
--- a/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb
+++ b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
@@ -4,7 +4,7 @@  HOMEPAGE = "https://dateutil.readthedocs.org"
 LICENSE = "BSD-3-Clause & Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996"
 
-SRC_URI[sha256sum] = "0123cacc1627ae19ddf3c27a5de5bd67ee4586fbdd6440d9748f8abb483d3e86"
+SRC_URI[sha256sum] = "78e73e19c63f5b20ffa567001531680d939dc042bf7850431877645523c66709"
 
 PYPI_PACKAGE = "python-dateutil"
 PIP_INSTALL_PACKAGE = "python_dateutil"