diff mbox series

[41/48] python3-typing-extensions: upgrade 4.9.0 -> 4.10.0

Message ID 1709105575-24259-41-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 91dd6f2878bcdbb6f9ba65927f6c6f981b0b3f1a
Headers show
Series [01/48] bash-completion: upgrade 2.11 -> 2.12.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 28, 2024, 7:32 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Add support for PEP 728, supporting the closed keyword argument and the special
 __extra_items__ key for TypedDict.
-Add support for PEP 742, adding typing_extensions.TypeIs.
-Drop runtime error when a read-only TypedDict item overrides a mutable one.
 Type checkers should still flag this as an error.
-Speedup issubclass() checks against simple runtime-checkable protocols by
 around 6% (backporting python/cpython#112717
-Fix a regression in the implementation of protocols where typing.Protocol
 classes that were not marked as @runtime_checkable would be unnecessarily
 introspected, potentially causing exceptions to be raised if the protocol had
 problematic members.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...-extensions_4.9.0.bb => python3-typing-extensions_4.10.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-typing-extensions_4.9.0.bb => python3-typing-extensions_4.10.0.bb} (91%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-typing-extensions_4.9.0.bb b/meta/recipes-devtools/python/python3-typing-extensions_4.10.0.bb
similarity index 91%
rename from meta/recipes-devtools/python/python3-typing-extensions_4.9.0.bb
rename to meta/recipes-devtools/python/python3-typing-extensions_4.10.0.bb
index 3553c597ac..8698a80cc5 100644
--- a/meta/recipes-devtools/python/python3-typing-extensions_4.9.0.bb
+++ b/meta/recipes-devtools/python/python3-typing-extensions_4.10.0.bb
@@ -15,7 +15,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=fcf6b249c2641540219a727f35d8d2c2"
 # The name on PyPi is slightly different.
 PYPI_PACKAGE = "typing_extensions"
 
-SRC_URI[sha256sum] = "23478f88c37f27d76ac8aee6c905017a143b0b1b886c3c9f66bc2fd94f9f5783"
+SRC_URI[sha256sum] = "b0abd7c89e8fb96f98db18d86106ff1d90ab692004eb746cf6eda2682f91b3cb"
 
 inherit pypi python_flit_core