[meta-python] python3-alembic upgrade 1.7.5 -> 1.7.6

Message ID 1645520625-1084-1-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-alembic upgrade 1.7.5 -> 1.7.6 | expand

Commit Message

XU Huan Feb. 22, 2022, 9:03 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

License-Update:
year updated to 2022

changelog:
===============================================================================
Add a new command alembic ensure_version, which will ensure that the Alembic
version table is present in the target database, but does not alter its
contents. Pull request courtesy Kai Mueller.

Fixed regression where usage of a with_variant() datatype in conjunction
with the existing_type option of op.alter_column() under batch mode would
lead to an internal exception.

Implemented support for recognizing and rendering SQLAlchemy “variant” types
going forward into SQLAlchemy 2.0, where the architecture of “variant”
datatypes will be changing.

Added a rule to the MySQL impl so that the translation between JSON / LONGTEXT
is accommodated by autogenerate, treating LONGTEXT from the server as
equivalent to an existing JSON in the model.

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 .../{python3-alembic_1.7.5.bb => python3-alembic_1.7.6.bb}    | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-alembic_1.7.5.bb => python3-alembic_1.7.6.bb} (66%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.7.5.bb b/meta-python/recipes-devtools/python/python3-alembic_1.7.6.bb
similarity index 66%
rename from meta-python/recipes-devtools/python/python3-alembic_1.7.5.bb
rename to meta-python/recipes-devtools/python/python3-alembic_1.7.6.bb
index 131d5d43a0..822b3c02b8 100644
--- a/meta-python/recipes-devtools/python/python3-alembic_1.7.5.bb
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.7.6.bb
@@ -1,10 +1,10 @@ 
 DESCRIPTION = "A database migration tool for SQLAlchemy"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c4ece55266dcdd02ce165b1ee0e490bb"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f5a8522010db1a393833988dbe2c7f0b"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "7c328694a2e68f03ee971e63c3bd885846470373a5b532cf2c9f1601c413b153"
+SRC_URI[sha256sum] = "6c0c05e9768a896d804387e20b299880fe01bc56484246b0dffe8075d6d3d847"
 
 PYPI_PACKAGE = "alembic"