diff mbox series

python3-bcrypt: allow building native package

Message ID 20240227101522.3155724-1-andreas.muetzel@emlix.com (mailing list archive)
State New
Headers show
Series python3-bcrypt: allow building native package | expand

Commit Message

Andreas Mützel Feb. 27, 2024, 10:15 a.m. UTC
The native and nativesdk variants of this package build fine, but the
corresponding BBCLASSEXTENDS was missing. Add it.

Signed-off-by: Andreas Mützel <andreas.muetzel@emlix.com>
---
 meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Ross Burton Feb. 27, 2024, 11:27 a.m. UTC | #1
Can you repost this to openembedded-core@lists.openembedded.org <mailto:openembedded-core@lists.openembedded.org> please?

Thanks,
Ross

> On 27 Feb 2024, at 10:15, Andreas Mützel via lists.yoctoproject.org <andreas.muetzel=emlix.com@lists.yoctoproject.org> wrote:
> 
> The native and nativesdk variants of this package build fine, but the
> corresponding BBCLASSEXTENDS was missing. Add it.
> 
> Signed-off-by: Andreas Mützel <andreas.muetzel@emlix.com>
> ---
> meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb | 2 ++
> 1 file changed, 2 insertions(+)
> 
> diff --git a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> index 8328594bad..72216c39c2 100644
> --- a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> +++ b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> @@ -34,3 +34,5 @@ RDEPENDS:${PN}:class-target += "\
>     python3-shell \
>     python3-six \
> "
> +
> +BBCLASSEXTEND = "native nativesdk"
> -- 
> 2.43.0
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#13278): https://lists.yoctoproject.org/g/poky/message/13278
> Mute This Topic: https://lists.yoctoproject.org/mt/104600131/6875888
> Group Owner: poky+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/poky/unsub [ross.burton@arm.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Richard Purdie Feb. 27, 2024, 11:32 a.m. UTC | #2
On Tue, 2024-02-27 at 11:15 +0100, Andreas Mützel wrote:
> The native and nativesdk variants of this package build fine, but the
> corresponding BBCLASSEXTENDS was missing. Add it.
> 
> Signed-off-by: Andreas Mützel <andreas.muetzel@emlix.com>
> ---
>  meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> index 8328594bad..72216c39c2 100644
> --- a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> +++ b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> @@ -34,3 +34,5 @@ RDEPENDS:${PN}:class-target += "\
>      python3-shell \
>      python3-six \
>  "
> +
> +BBCLASSEXTEND = "native nativesdk"

As well as sending to the correct list, could you add a bit more
justification/information about what needs this?

Adding these variants isn't "free" as it has parsing and maintenance
overhead so we try not to add this unless we need to.

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
index 8328594bad..72216c39c2 100644
--- a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
+++ b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
@@ -34,3 +34,5 @@  RDEPENDS:${PN}:class-target += "\
     python3-shell \
     python3-six \
 "
+
+BBCLASSEXTEND = "native nativesdk"