diff mbox series

curl: improve reproducibility

Message ID 20240226135531.281696-1-omatiush@cisco.com
State New
Headers show
Series curl: improve reproducibility | expand

Commit Message

Nativesdk package contains host references in output packages.
Remove them.

Signed-off-by: Oleh Matiusha <omatiush@cisco.com>
---
 meta/recipes-support/curl/curl_7.85.0.bb | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Alexander Kanavin Feb. 26, 2024, 2:41 p.m. UTC | #1
It’s better to separate the processing into its own function so you don’t
have to copy paste it from target install.

Alex

On Mon 26. Feb 2024 at 14.55, Oleh Matiusha via lists.openembedded.org
<omatiush=cisco.com@lists.openembedded.org> wrote:

> Nativesdk package contains host references in output packages.
> Remove them.
>
> Signed-off-by: Oleh Matiusha <omatiush@cisco.com>
> ---
>  meta/recipes-support/curl/curl_7.85.0.bb | 10 ++++++++++
>  1 file changed, 10 insertions(+)
>
> diff --git a/meta/recipes-support/curl/curl_7.85.0.bb
> b/meta/recipes-support/curl/curl_7.85.0.bb
> index 1e71ed821e..2d60f9aba1 100644
> --- a/meta/recipes-support/curl/curl_7.85.0.bb
> +++ b/meta/recipes-support/curl/curl_7.85.0.bb
> @@ -110,6 +110,16 @@ do_install:append:class-target() {
>             ${D}${bindir}/curl-config
>  }
>
> +do_install:append:class-nativesdk() {
> +       # cleanup buildpaths from curl-config
> +       sed -i \
> +           -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
> +           -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
> +           -e 's|${DEBUG_PREFIX_MAP}||g' \
> +           -e 's|${@" ".join(d.getVar("DEBUG_PREFIX_MAP").split())}||g' \
> +           ${D}${bindir}/curl-config
> +}
> +
>  do_compile_ptest() {
>         oe_runmake test
>         oe_runmake -C ${B}/tests/server
> --
> 2.33.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#196204):
> https://lists.openembedded.org/g/openembedded-core/message/196204
> Mute This Topic: https://lists.openembedded.org/mt/104582066/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-support/curl/curl_7.85.0.bb b/meta/recipes-support/curl/curl_7.85.0.bb
index 1e71ed821e..2d60f9aba1 100644
--- a/meta/recipes-support/curl/curl_7.85.0.bb
+++ b/meta/recipes-support/curl/curl_7.85.0.bb
@@ -110,6 +110,16 @@  do_install:append:class-target() {
 	    ${D}${bindir}/curl-config
 }
 
+do_install:append:class-nativesdk() {
+	# cleanup buildpaths from curl-config
+	sed -i \
+	    -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
+	    -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
+	    -e 's|${DEBUG_PREFIX_MAP}||g' \
+	    -e 's|${@" ".join(d.getVar("DEBUG_PREFIX_MAP").split())}||g' \
+	    ${D}${bindir}/curl-config
+}
+
 do_compile_ptest() {
 	oe_runmake test
 	oe_runmake -C ${B}/tests/server