diff mbox series

[meta-python,1/2] python3-pybind11: Migrate to python_setuptools_build_meta

Message ID 20240226114154.1033676-1-niko.mauno@vaisala.com
State Accepted
Headers show
Series [meta-python,1/2] python3-pybind11: Migrate to python_setuptools_build_meta | expand

Commit Message

Niko Mauno Feb. 26, 2024, 11:41 a.m. UTC
From: Niko Mauno <niko.mauno@vaisala.com>

Switch from setuptools3.bbclass to python_setuptools_build_meta.bblass
which reflects
https://github.com/pybind/pybind11/blob/v2.11.1/pyproject.toml#L3 and
mitigates following warning during do_compile:

  .../python3-pybind11/2.11.1/recipe-sysroot-native/usr/lib/python3.11/site-packages/setuptools/_distutils/cmd.py:66: SetuptoolsDeprecationWarning: setup.py install is deprecated.

Here we also fix remaining minor style issue in task declarations
(use four space indentation instead of three).

Reported-by: Tim Orling <ticotimo@gmail.com>
Closes: https://lists.openembedded.org/g/openembedded-devel/message/108748
Signed-off-by: Niko Mauno <niko.mauno@vaisala.com>
---
 .../python/python3-pybind11_2.11.1.bb         | 23 +++++++++----------
 1 file changed, 11 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
index f94ef3637..13f63b7c6 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
@@ -2,31 +2,30 @@  SUMMARY = "Seamless operability between C++11 and Python"
 HOMEPAGE = "https://github.com/pybind/pybind11"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
+DEPENDS = "\
+    python3-cmake-native \
+    python3-ninja-native \
+"
 
 SRCREV = "8a099e44b3d5f85b20f05828d919d2332a8de841"
 SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https"
 
 S = "${WORKDIR}/git"
 
-inherit cmake setuptools3
+inherit cmake python_setuptools_build_meta
 
 EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
 
-PIP_INSTALL_DIST_PATH = "${S}/dist"
-PIP_INSTALL_PACKAGE = "pybind11"
-
-do_configure() {
-   cmake_do_configure
+do_configure:append() {
+    cmake_do_configure
 }
 
-do_compile() {
-   setuptools3_do_compile
-   cmake_do_compile
+do_compile:append() {
+    cmake_do_compile
 }
 
-do_install() {
-   setuptools3_do_install
-   cmake_do_install
+do_install:append() {
+    cmake_do_install
 }
 
 BBCLASSEXTEND = "native nativesdk"