diff mbox series

recipetool: Fix errors with meta-poky bbappend

Message ID 20240223143043.1053070-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 7cf85204f0943bf741ffce5c4105340197c714df
Headers show
Series recipetool: Fix errors with meta-poky bbappend | expand

Commit Message

Richard Purdie Feb. 23, 2024, 2:30 p.m. UTC
When a new base-files bbappend was added to meta-poky, it causes selftest
failures. Whilst this isn't ideal, workaround that issue for now since
the append is being added for security visibility and changing the tests
to support this more generically looks invasive.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/lib/oeqa/selftest/cases/recipetool.py | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/lib/oeqa/selftest/cases/recipetool.py b/meta/lib/oeqa/selftest/cases/recipetool.py
index 2eca1800de1..aebea42502b 100644
--- a/meta/lib/oeqa/selftest/cases/recipetool.py
+++ b/meta/lib/oeqa/selftest/cases/recipetool.py
@@ -48,6 +48,8 @@  class RecipetoolBase(devtool.DevtoolTestCase):
         self.testfile = os.path.join(self.tempdir, 'testfile')
         with open(self.testfile, 'w') as f:
             f.write('Test file\n')
+        config = 'BBMASK += "meta-poky/recipes-core/base-files/base-files_%.bbappend"\n'
+        self.append_config(config)
 
     def tearDownLocal(self):
         runCmd('rm -rf %s/recipes-*' % self.templayerdir)