diff mbox series

[meta-perl,2/3] meta-perl-image-ptest: add PTESTS_PROBLEMS_META_PERL

Message ID 61b3add8a0c6454ad3b0eb3636fae0ab5a6183d9.1708573650.git.tim.orling@konsulko.com
State Accepted
Headers show
Series [meta-oe,1/3] meta-oe-image-ptest: add PTESTS_PROBLEMS_META_OE | expand

Commit Message

Tim Orling Feb. 22, 2024, 4:26 a.m. UTC
In oe-core, PTESTS_PROBLEMS are also enabled, so even though
the recipe might have failures or the ptests do not run cleanly,
the BBCLASSEXTEND still works.

Enable the same behavior for meta-perl.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb | 2 +-
 meta-perl/recipes-core/images/meta-perl-image-ptest.bb     | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb b/meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb
index e2cafa98a5..9efe5087f0 100644
--- a/meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb
+++ b/meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb
@@ -9,7 +9,7 @@  REQUIRED_DISTRO_FEATURES = "ptest"
 require conf/include/ptest-packagelists-meta-perl.inc
 
 # Include the full set of ptests
-PTESTS_META_PERL = "${PTESTS_FAST_META_PERL} ${PTESTS_SLOW_META_PERL}"
+PTESTS_META_PERL = "${PTESTS_FAST_META_PERL} ${PTESTS_SLOW_META_PERL} ${PTESTS_PROBLEMS_META_PERL}"
 
 do_testimage[noexec] = "1"
 do_testimage[depends] = "${@' '.join(['meta-perl-image-ptest-'+x+':do_testimage' for x in d.getVar('PTESTS_META_PERL').split()])}"
diff --git a/meta-perl/recipes-core/images/meta-perl-image-ptest.bb b/meta-perl/recipes-core/images/meta-perl-image-ptest.bb
index 7905977828..94d77b97f0 100644
--- a/meta-perl/recipes-core/images/meta-perl-image-ptest.bb
+++ b/meta-perl/recipes-core/images/meta-perl-image-ptest.bb
@@ -9,7 +9,7 @@  require conf/include/ptest-packagelists-meta-perl.inc
 DESCRIPTION += "Also including the ${MCNAME} ptest package."
 HOMEPAGE = "https://www.openembedded.org/"
 
-PTESTS_META_PERL = "${PTESTS_SLOW_META_PERL} ${PTESTS_FAST_META_PERL}"
+PTESTS_META_PERL = "${PTESTS_SLOW_META_PERL} ${PTESTS_FAST_META_PERL} ${PTESTS_PROBLEMS_META_PERL}"
 
 IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh"