diff mbox series

[meta-python,v2,1/3] python3-pytest-lazy-fixtures: add 1.0.5

Message ID 266899d7096aec9a40ad229718a5056f879d9c78.1708403129.git.tim.orling@konsulko.com
State Accepted
Headers show
Series [meta-python,v2,1/3] python3-pytest-lazy-fixtures: add 1.0.5 | expand

Commit Message

Tim Orling Feb. 20, 2024, 4:31 a.m. UTC
Use your fixtures in @pytest.mark.parametrize.

This project was inspired by pytest-lazy-fixture.

Improvements that have been made in this project:

1. You can use fixtures in any data structures
2. You can access the attributes of fixtures
3. You can use functions in fixtures

* Dependency for python3-prettytable ptest.
  (Not the same as python3-pytest-lazy-fixture without the s)
* Upstream does not package tests/ in the sdist on pypi, so
  we do not try to enable ptest at this time (it would require
  using git fetcher instead of pypi.bbclass).
* The ptest for the predecessor (python3-pytest-lazy-fixture
  without the s) was already in PTEST_PROBLEMS, meaning its
  ptests did not run cleanly.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
Changes in v2:
Rebased on top of rebased timo/drop-PYTHON_PN on top of master-next

 .../python3-pytest-lazy-fixtures_1.0.5.bb     | 21 +++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb
new file mode 100644
index 0000000000..dcf662a2c8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixtures_1.0.5.bb
@@ -0,0 +1,21 @@ 
+SUMMARY = "Allows you to use fixtures in @pytest.mark.parametrize."
+DESCRIPTION = "Use your fixtures in @pytest.mark.parametrize. \
+\
+This project was inspired by pytest-lazy-fixture.\
+\
+Improvements that have been made in this project:\
+\
+* You can use fixtures in any data structures\
+* You can access the attributes of fixtures\
+* You can use functions in fixtures"
+HOMEPAGE = "https://github.com/dev-petrov/pytest-lazy-fixtures"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4475e66fcfabe27395e6764c8f69c876"
+
+SRC_URI[sha256sum] = "066b253a94c249e6d9cdfad465e2503d2219139fb468d8f687243dfde39ab9cb"
+
+inherit pypi python_poetry_core
+
+PYPI_PACKAGE = "pytest_lazy_fixtures"
+
+RDEPENDS:${PN} = "python3-pytest"