diff mbox series

[meta-python,23/23] python3-gevent: upgrade 23.9.1 -> 24.2.1

Message ID 1708333346-17704-23-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-gnome,01/23] babl: upgrade 0.1.106 -> 0.1.108 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 19, 2024, 9:02 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-_setuputils.py-Do-not-add-sys_inc_dir.patch
refreshed for 24.2.1

Changelog:
===========
-Add support for Python patch releases 3.11.8 and 3.12.2, which changed internal
 details of threading.
-Errors raised from subprocess.Popen may not have a filename set.
-SSLSocket.recv_into and SSLSocket.read no longer require the buffer to
 implement len and now work with buffers whose size is not 1.
-gh-108310: Fix CVE-2023-40217: Check for & avoid the ssl pre-close flaw.
-Drop setuptools to a soft test dependency.
-Drop support for very old versions of CFFI.
-Update bundled c-ares from 1.19.1 to 1.26.0.
-Locks created by gevent, but acquired from multiple different threads (not
 recommended), no longer spin to implement timeouts and interruptible blocking.
 Instead, they use the native functionality of the Python 3 lock.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../0001-_setuputils.py-Do-not-add-sys_inc_dir.patch | 12 +++++-------
 ...on3-gevent_23.9.1.bb => python3-gevent_24.2.1.bb} |  2 +-
 2 files changed, 6 insertions(+), 8 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-gevent_23.9.1.bb => python3-gevent_24.2.1.bb} (93%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-gevent/0001-_setuputils.py-Do-not-add-sys_inc_dir.patch b/meta-python/recipes-devtools/python/python3-gevent/0001-_setuputils.py-Do-not-add-sys_inc_dir.patch
index ac8b031cf..49903d6ce 100644
--- a/meta-python/recipes-devtools/python/python3-gevent/0001-_setuputils.py-Do-not-add-sys_inc_dir.patch
+++ b/meta-python/recipes-devtools/python/python3-gevent/0001-_setuputils.py-Do-not-add-sys_inc_dir.patch
@@ -1,4 +1,4 @@ 
-From f3267ad7994a4b66e6bcf72cb0e418105f77bd52 Mon Sep 17 00:00:00 2001
+From 9eb453283a7ac8a9b1dd3eac86d936c7a430476b Mon Sep 17 00:00:00 2001
 From: Khem Raj <raj.khem@gmail.com>
 Date: Tue, 11 Oct 2022 17:37:01 -0700
 Subject: [PATCH] _setuputils.py: Do not add sys_inc_dir
@@ -10,15 +10,16 @@  we really do not need setuptools to deduce it for us.
 
 Upstream-Status: Inappropriate [ Cross-compile specific ]
 Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
 ---
  _setuputils.py | 3 +--
  1 file changed, 1 insertion(+), 2 deletions(-)
 
 diff --git a/_setuputils.py b/_setuputils.py
-index d98f716..31134a4 100644
+index 4c25e00..23fdfe1 100644
 --- a/_setuputils.py
 +++ b/_setuputils.py
-@@ -161,7 +161,6 @@ def get_include_dirs(*extra_paths):
+@@ -164,7 +164,6 @@ def get_include_dirs(*extra_paths):
      # Neither sysconfig dir is not enough if we're in a virtualenv; the greenlet.h
      # header goes into a site/ subdir. See https://github.com/pypa/pip/issues/4610
      dist_inc_dir = os.path.abspath(dist_sysconfig.get_python_inc()) # 1
@@ -26,7 +27,7 @@  index d98f716..31134a4 100644
      venv_include_dir = os.path.join(
          sys.prefix, 'include', 'site',
          'python' + sysconfig.get_python_version()
-@@ -175,7 +174,7 @@ def get_include_dirs(*extra_paths):
+@@ -178,7 +177,7 @@ def get_include_dirs(*extra_paths):
  
      return [
          p
@@ -35,6 +36,3 @@  index d98f716..31134a4 100644
          if os.path.exists(p)
      ]
  
--- 
-2.38.0
-
diff --git a/meta-python/recipes-devtools/python/python3-gevent_23.9.1.bb b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
similarity index 93%
rename from meta-python/recipes-devtools/python/python3-gevent_23.9.1.bb
rename to meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
index 0caebce28..ebde34d56 100644
--- a/meta-python/recipes-devtools/python/python3-gevent_23.9.1.bb
+++ b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
@@ -13,7 +13,7 @@  RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \
 
 SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch"
 
-SRC_URI[sha256sum] = "72c002235390d46f94938a96920d8856d4ffd9ddf62a303a0d7c118894097e34"
+SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056"
 
 inherit pypi setuptools3