diff mbox series

[meta-python,16/23] python3-bidict: upgrade 0.22.1 -> 0.23.0

Message ID 1708333346-17704-16-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-gnome,01/23] babl: upgrade 0.1.106 -> 0.1.108 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 19, 2024, 9:02 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update: Copyright year updated to 2024

Changelog:
============
-Drop support for Python 3.7, which reached end of life on 2023-06-27, and take
 advantage of features available in Python 3.8+.
-Remove FrozenOrderedBidict now that Python 3.7 is no longer supported.
-Remove namedbidict due to low usage.
-Remove the kv field of OnDup which specified the OnDupAction to take in the
 case of Key and Value Duplication.
-Improve type hints for the inv shortcut alias for inverse.
-Fix a bug where calls like bidict(None), bi.update(False)
-All __init__(), update(), and related methods now handle SupportsKeysAndGetItem
 objects that are not Mappings the same way that MutableMapping.update() does,
 before falling back to handling the provided object as an iterable of pairs.
-The repr() of ordered bidicts now matches that of regular bidicts
-This tracks with the change to collections.OrderedDict's repr() in Python 3.12.
-Test with Python 3.12 in CI.
-Drop use of Trove classifiers that declare support for specific Python versions
 in package metadata.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-bidict_0.22.1.bb => python3-bidict_0.23.0.bb}    | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-bidict_0.22.1.bb => python3-bidict_0.23.0.bb} (62%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-bidict_0.22.1.bb b/meta-python/recipes-devtools/python/python3-bidict_0.23.0.bb
similarity index 62%
rename from meta-python/recipes-devtools/python/python3-bidict_0.22.1.bb
rename to meta-python/recipes-devtools/python/python3-bidict_0.23.0.bb
index 1ed0af81a..5667e4927 100644
--- a/meta-python/recipes-devtools/python/python3-bidict_0.22.1.bb
+++ b/meta-python/recipes-devtools/python/python3-bidict_0.23.0.bb
@@ -2,9 +2,9 @@  SUMMARY = "The bidirectional mapping library for Python."
 DESCRIPTION = "The bidirectional mapping library for Python."
 HOMEPAGE = "https://bidict.readthedocs.io/"
 LICENSE = "MPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=858e74278ef3830d46481172ae03c819"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e907308cc9356afa99ac0eec6b20211b"
 
-SRC_URI[sha256sum] = "1e0f7f74e4860e6d0943a05d4134c63a2fad86f3d4732fb265bd79e4e856d81d"
+SRC_URI[sha256sum] = "3959ca59d4d6997702d642bf1e5fd93cba299863723fc289545198f70c468578"
 
 inherit pypi python_setuptools_build_meta