diff mbox series

[[meta-networking] fix dropwatch] dropwatch tools compile with local head file,but it not matched with our real head file form kernel.(net_dropmon.h) net_dropmon.h in dropwatch local src/net_dropmon.h. linux kernel also have it in include/uapi/linux/net_d

Message ID 20240218134708.63400-1-chen_heyun@163.com
State Under Review
Headers show
Series [[meta-networking] fix dropwatch] dropwatch tools compile with local head file,but it not matched with our real head file form kernel.(net_dropmon.h) net_dropmon.h in dropwatch local src/net_dropmon.h. linux kernel also have it in include/uapi/linux/net_d | expand

Commit Message

chenheyun Feb. 18, 2024, 1:47 p.m. UTC
for example,our kernel is linux5.10:

Comments

Khem Raj Feb. 18, 2024, 3:15 p.m. UTC | #1
On Sun, Feb 18, 2024 at 5:47 AM chenheyun <chen_heyun@163.com> wrote:
>
> for example,our kernel is linux5.10:
> diff tmp/work/cortexa57-poky-linux/dropwatch/1.5.4+git-r0/recipe-sysroot/usr/
> include/linux/net_dropmon.h tmp/work/cortexa57-poky-linux/dropwatch/1.5.4+git-r0/git/src/net_dropmon.h
> 1c1,3
> <
> 95a94
> >       NET_DM_ATTR_REASON,                     /* string */
>
> it will cause missmatch when we use drop watch in lower kernel version(v5.10),
> will cause dropwatch and kernel drop_monitor module missmatch with netlink talk.
> we should build it with sysroot which comes from match kernel head file.
>

subject line and commit message is a bit confusing, please follow the
commit message format

recipe: Summary of change

Description of the chage...


> Signed-off-by: chenheyun <chen_heyun@163.com>
> ---
>  ...th-sysroot-head-file-instead-of-loca.patch | 28 +++++++++++++++++++
>  .../dropwatch/dropwatch_1.5.4.bb              |  4 ++-
>  2 files changed, 31 insertions(+), 1 deletion(-)
>  create mode 100755 meta-networking/recipes-support/dropwatch/dropwatch/0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch
>
> diff --git a/meta-networking/recipes-support/dropwatch/dropwatch/0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch b/meta-networking/recipes-support/dropwatch/dropwatch/0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch
> new file mode 100755
> index 000000000..33b72e05f
> --- /dev/null
> +++ b/meta-networking/recipes-support/dropwatch/dropwatch/0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch
> @@ -0,0 +1,28 @@
> +From 4872c52f55f9cb089e6681c3f1926663145b52ae Mon Sep 17 00:00:00 2001
> +From: chenheyun <chen_heyun@163.com>
> +Date: Sun, 18 Feb 2024 05:08:25 -0800
> +Subject: [PATCH] fix bug: build with sysroot head file instead of local head
> + file:net_dropmon.h
> +

Please submit this patch upstream to dropwatch as well and then add
Upstream-Status tag to this patch.

> +Signed-off-by: chenheyun <chen_heyun@163.com>
> +---
> + src/main.c | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/src/main.c b/src/main.c
> +index e4746d9..81dc4da 100644
> +--- a/src/main.c
> ++++ b/src/main.c
> +@@ -26,8 +26,8 @@
> + #include <netlink/netlink.h>
> + #include <netlink/genl/genl.h>
> + #include <netlink/genl/ctrl.h>
> ++#include <net_dropmon.h>
> +
> +-#include "net_dropmon.h"
> + #include "lookup.h"
> +
> + /*
> +--
> +2.25.1
> +
> diff --git a/meta-networking/recipes-support/dropwatch/dropwatch_1.5.4.bb b/meta-networking/recipes-support/dropwatch/dropwatch_1.5.4.bb
> index e3dbac4a2..baa9398a1 100644
> --- a/meta-networking/recipes-support/dropwatch/dropwatch_1.5.4.bb
> +++ b/meta-networking/recipes-support/dropwatch/dropwatch_1.5.4.bb
> @@ -8,7 +8,9 @@ SECTION = "net/misc"
>  LICENSE = "GPL-2.0-or-later"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
>
> -SRC_URI = "git://github.com/nhorman/dropwatch.git;protocol=https;nobranch=1"
> +SRC_URI = "git://github.com/nhorman/dropwatch.git;protocol=https;nobranch=1 \
> +                 file://0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch \
> +"
>  SRCREV = "1e7e487a019a7c02f1f429c4d3a4647fa3787a13"
>
>  S = "${WORKDIR}/git"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108838): https://lists.openembedded.org/g/openembedded-devel/message/108838
> Mute This Topic: https://lists.openembedded.org/mt/104427329/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
chenheyun Feb. 18, 2024, 3:33 p.m. UTC | #2
hello,
thanks for your reply.
I have no experience to your reply.
then,i am sure that i should change my commit message,then should me repeat send email like this?(i am doubt that send email new that is not associated with this, or iterate this,but i am doubt that how to iterate this ).please help me,thanks.

thanks,i will submit this patch upstream to dropwatch, doing.

best wishes for you
diff mbox series

Patch

diff tmp/work/cortexa57-poky-linux/dropwatch/1.5.4+git-r0/recipe-sysroot/usr/
include/linux/net_dropmon.h tmp/work/cortexa57-poky-linux/dropwatch/1.5.4+git-r0/git/src/net_dropmon.h
1c1,3
<
95a94
>       NET_DM_ATTR_REASON,                     /* string */

it will cause missmatch when we use drop watch in lower kernel version(v5.10),
will cause dropwatch and kernel drop_monitor module missmatch with netlink talk.
we should build it with sysroot which comes from match kernel head file.

Signed-off-by: chenheyun <chen_heyun@163.com>
---
 ...th-sysroot-head-file-instead-of-loca.patch | 28 +++++++++++++++++++
 .../dropwatch/dropwatch_1.5.4.bb              |  4 ++-
 2 files changed, 31 insertions(+), 1 deletion(-)
 create mode 100755 meta-networking/recipes-support/dropwatch/dropwatch/0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch

diff --git a/meta-networking/recipes-support/dropwatch/dropwatch/0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch b/meta-networking/recipes-support/dropwatch/dropwatch/0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch
new file mode 100755
index 000000000..33b72e05f
--- /dev/null
+++ b/meta-networking/recipes-support/dropwatch/dropwatch/0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch
@@ -0,0 +1,28 @@ 
+From 4872c52f55f9cb089e6681c3f1926663145b52ae Mon Sep 17 00:00:00 2001
+From: chenheyun <chen_heyun@163.com>
+Date: Sun, 18 Feb 2024 05:08:25 -0800
+Subject: [PATCH] fix bug: build with sysroot head file instead of local head
+ file:net_dropmon.h
+
+Signed-off-by: chenheyun <chen_heyun@163.com>
+---
+ src/main.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/main.c b/src/main.c
+index e4746d9..81dc4da 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -26,8 +26,8 @@
+ #include <netlink/netlink.h>
+ #include <netlink/genl/genl.h>
+ #include <netlink/genl/ctrl.h>
++#include <net_dropmon.h>
+ 
+-#include "net_dropmon.h"
+ #include "lookup.h"
+ 
+ /*
+-- 
+2.25.1
+
diff --git a/meta-networking/recipes-support/dropwatch/dropwatch_1.5.4.bb b/meta-networking/recipes-support/dropwatch/dropwatch_1.5.4.bb
index e3dbac4a2..baa9398a1 100644
--- a/meta-networking/recipes-support/dropwatch/dropwatch_1.5.4.bb
+++ b/meta-networking/recipes-support/dropwatch/dropwatch_1.5.4.bb
@@ -8,7 +8,9 @@  SECTION = "net/misc"
 LICENSE = "GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
 
-SRC_URI = "git://github.com/nhorman/dropwatch.git;protocol=https;nobranch=1"
+SRC_URI = "git://github.com/nhorman/dropwatch.git;protocol=https;nobranch=1 \
+		  file://0001-fix-bug-build-with-sysroot-head-file-instead-of-loca.patch \
+"
 SRCREV = "1e7e487a019a7c02f1f429c4d3a4647fa3787a13"
 
 S = "${WORKDIR}/git"