diff mbox series

lynis: Add missing runtime dependencies

Message ID 20240215225757.307579-1-m.belouarga@technologyandstrategy.com
State New
Headers show
Series lynis: Add missing runtime dependencies | expand

Commit Message

belouargamohamed@gmail.com Feb. 15, 2024, 10:57 p.m. UTC
From: BELOUARGA Mohamed <m.belouarga@technologyandstrategy.com>

Lynis tool needs ip, ss, tr and netstat.
If they are missing Lynis skips some important audit tests.

Signed-off-by: BELOUARGA Mohamed <m.belouarga@technologyandstrategy.com>
---
 recipes-compliance/lynis/lynis_3.0.9.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Michael Opdenacker Feb. 16, 2024, 7:32 a.m. UTC | #1
Hi Mohamed

On 2/15/24 at 23:57, belouargamohamed@gmail.com wrote:
> From: BELOUARGA Mohamed <m.belouarga@technologyandstrategy.com>
>
> Lynis tool needs ip, ss, tr and netstat.
> If they are missing Lynis skips some important audit tests.
>
> Signed-off-by: BELOUARGA Mohamed <m.belouarga@technologyandstrategy.com>
> ---
>   recipes-compliance/lynis/lynis_3.0.9.bb | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/recipes-compliance/lynis/lynis_3.0.9.bb b/recipes-compliance/lynis/lynis_3.0.9.bb
> index 5b5864c..b8b97a5 100644
> --- a/recipes-compliance/lynis/lynis_3.0.9.bb
> +++ b/recipes-compliance/lynis/lynis_3.0.9.bb
> @@ -41,4 +41,4 @@ do_install () {
>   FILES:${PN} += "${sysconfdir}/developer.prf ${sysconfdir}/default.prf"
>   FILES:${PN}-doc += "lynis.8 FAQ README CHANGELOG.md CONTRIBUTIONS.md CONTRIBUTORS.md"
>   
> -RDEPENDS:${PN} += "procps findutils"
> +RDEPENDS:${PN} += "procps findutils coreutils iproute2-ip iproute2-ss net-tools"


Thanks for the patch!
Maybe you should send it again with the "[meta-security]" prefix, 
otherwise, the meta-security maintainers may miss it.

See https://git.yoctoproject.org/meta-security/tree/README.md
Thanks again
Michael.
belouargamohamed@gmail.com Feb. 17, 2024, 1:01 p.m. UTC | #2
Hey Michael,

I did what you asked, can you please remove my previous patches ?

Thanks,
BELOUARGA Mohamed
Michael Opdenacker Feb. 19, 2024, 9 a.m. UTC | #3
Hi Mohamed

On 2/17/24 at 14:01, belouargamohamed@gmail.com wrote:
> Hey Michael,
>
> I did what you asked, can you please remove my previous patches ?


Thanks a lot!
Actually, I haven't merged your previous patches yet, so don't hesitate 
to send the new ones.

Thanks again
Michael.
diff mbox series

Patch

diff --git a/recipes-compliance/lynis/lynis_3.0.9.bb b/recipes-compliance/lynis/lynis_3.0.9.bb
index 5b5864c..b8b97a5 100644
--- a/recipes-compliance/lynis/lynis_3.0.9.bb
+++ b/recipes-compliance/lynis/lynis_3.0.9.bb
@@ -41,4 +41,4 @@  do_install () {
 FILES:${PN} += "${sysconfdir}/developer.prf ${sysconfdir}/default.prf"
 FILES:${PN}-doc += "lynis.8 FAQ README CHANGELOG.md CONTRIBUTIONS.md CONTRIBUTORS.md" 
 
-RDEPENDS:${PN} += "procps findutils"
+RDEPENDS:${PN} += "procps findutils coreutils iproute2-ip iproute2-ss net-tools"