diff mbox series

[AUH] acl: upgrading to 2.3.2 SUCCEEDED

Message ID 0101018dadd3ac9d-d7859e99-e1b5-4d22-899a-ea39c975b0bc-000000@us-west-2.amazonses.com
State New
Headers show
Series [AUH] acl: upgrading to 2.3.2 SUCCEEDED | expand

Commit Message

auh@yoctoproject.org Feb. 15, 2024, 5:32 p.m. UTC
Hello,

this email is a notification from the Auto Upgrade Helper
that the automatic attempt to upgrade the recipe *acl* to *2.3.2* has Succeeded.

Next steps:
    - apply the patch: git am 0001-acl-upgrade-2.3.1-2.3.2.patch
    - check the changes to upstream patches and summarize them in the commit message,
    - compile an image that contains the package
    - perform some basic sanity tests
    - amend the patch and sign it off: git commit -s --reset-author --amend
    - send it to the appropriate mailing list

Alternatively, if you believe the recipe should not be upgraded at this time,
you can fill RECIPE_NO_UPDATE_REASON in respective recipe file so that
automatic upgrades would no longer be attempted.

Please review the attached files for further information and build/update failures.
Any problem please file a bug at https://bugzilla.yoctoproject.org/enter_bug.cgi?product=Automated%20Update%20Handler

Regards,
The Upgrade Helper

-- >8 --
From 72ec640d2b72e8580165c4ad481b0848c533a193 Mon Sep 17 00:00:00 2001
From: Upgrade Helper <auh@yoctoproject.org>
Date: Thu, 15 Feb 2024 16:26:15 +0000
Subject: [PATCH] acl: upgrade 2.3.1 -> 2.3.2

---
 ...rtable-version-of-dirent-and-readdir.patch | 39 -------------------
 .../0001-test-patch-out-failing-bits.patch    |  6 +--
 ...dcode-the-build-path-into-a-helper-l.patch |  7 ++--
 .../attr/{acl_2.3.1.bb => acl_2.3.2.bb}       |  3 +-
 4 files changed, 7 insertions(+), 48 deletions(-)
 delete mode 100644 meta/recipes-support/attr/acl/0001-chacl-Use-portable-version-of-dirent-and-readdir.patch
 rename meta/recipes-support/attr/{acl_2.3.1.bb => acl_2.3.2.bb} (94%)
diff mbox series

Patch

diff --git a/meta/recipes-support/attr/acl/0001-chacl-Use-portable-version-of-dirent-and-readdir.patch b/meta/recipes-support/attr/acl/0001-chacl-Use-portable-version-of-dirent-and-readdir.patch
deleted file mode 100644
index 775675e1f2..0000000000
--- a/meta/recipes-support/attr/acl/0001-chacl-Use-portable-version-of-dirent-and-readdir.patch
+++ /dev/null
@@ -1,39 +0,0 @@ 
-From 1a5671a4eb13b81b98c3e71f00370781563f66d8 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 10 Nov 2022 17:57:24 -0800
-Subject: [PATCH] chacl: Use portable version of dirent and readdir
-
-Using 64bit versions on 32bit architectures should be enabled with
---enable-largefile, this makes it portable across musl and glibc
-
-Upstream-Status: Backport [https://git.savannah.nongnu.org/cgit/acl.git/commit/?id=2b42f64737adf6a2ddd491213580d6e9cdd2f5af]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- tools/chacl.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tools/chacl.c b/tools/chacl.c
-index 525a7ff..8fff875 100644
---- a/tools/chacl.c
-+++ b/tools/chacl.c
-@@ -320,7 +320,7 @@ walk_dir(acl_t acl, acl_t dacl, const char *fname)
- {
- 	int failed = 0;
- 	DIR *dir;
--	struct dirent64 *d;
-+	struct dirent *d;
- 	char *name;
- 
- 	if ((dir = opendir(fname)) == NULL) {
-@@ -332,7 +332,7 @@ walk_dir(acl_t acl, acl_t dacl, const char *fname)
- 		return(0);	/* got a file, not an error */
- 	}
- 
--	while ((d = readdir64(dir)) != NULL) {
-+	while ((d = readdir(dir)) != NULL) {
- 		/* skip "." and ".." entries */
- 		if (strcmp(d->d_name, ".") == 0 || strcmp(d->d_name, "..") == 0)
- 			continue;
--- 
-2.38.1
-
diff --git a/meta/recipes-support/attr/acl/0001-test-patch-out-failing-bits.patch b/meta/recipes-support/attr/acl/0001-test-patch-out-failing-bits.patch
index ba2ffee5d2..6cb515b830 100644
--- a/meta/recipes-support/attr/acl/0001-test-patch-out-failing-bits.patch
+++ b/meta/recipes-support/attr/acl/0001-test-patch-out-failing-bits.patch
@@ -1,4 +1,4 @@ 
-From 9e08219e0e99ee2589cf35fa8d52cef3515accce Mon Sep 17 00:00:00 2001
+From e364d5396b1a6e5264fdc0b2ccd719b131e4f95b Mon Sep 17 00:00:00 2001
 From: Alexander Kanavin <alex.kanavin@gmail.com>
 Date: Thu, 12 Dec 2019 15:47:49 +0100
 Subject: [PATCH] test: patch out failing bits
@@ -9,6 +9,7 @@  test is only executed under sudo.
 
 Upstream-Status: Inappropriate [disabling tests instead of fixing them properly]
 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+
 ---
  test/root/permissions.test | 13 -------------
  1 file changed, 13 deletions(-)
@@ -58,6 +59,3 @@  index 8f8f825..21e8a95 100644
  	$ : > f
  	$ : <> f
  	>~ .*f: Permission denied$
--- 
-2.17.1
-
diff --git a/meta/recipes-support/attr/acl/0001-tests-do-not-hardcode-the-build-path-into-a-helper-l.patch b/meta/recipes-support/attr/acl/0001-tests-do-not-hardcode-the-build-path-into-a-helper-l.patch
index 57ef0bb728..5dd54f64fb 100644
--- a/meta/recipes-support/attr/acl/0001-tests-do-not-hardcode-the-build-path-into-a-helper-l.patch
+++ b/meta/recipes-support/attr/acl/0001-tests-do-not-hardcode-the-build-path-into-a-helper-l.patch
@@ -1,16 +1,17 @@ 
-From 39d332a8801de5d9ef09dacb3dba85c208b7b2ad Mon Sep 17 00:00:00 2001
+From be94bc9d516a424e6d2048eb952087f39f3a23ba Mon Sep 17 00:00:00 2001
 From: Alexander Kanavin <alex.kanavin@gmail.com>
 Date: Thu, 12 Dec 2019 13:45:52 +0100
 Subject: [PATCH] tests: do not hardcode the build path into a helper library
 
 Upstream-Status: Inappropriate [oe-core specific]
 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+
 ---
  test/Makemodule.am | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/test/Makemodule.am b/test/Makemodule.am
-index 17d4927..015de7f 100644
+index e1d715d..cffe732 100644
 --- a/test/Makemodule.am
 +++ b/test/Makemodule.am
 @@ -30,7 +30,7 @@ EXTRA_DIST += \
@@ -21,4 +22,4 @@  index 17d4927..015de7f 100644
 +libtestlookup_la_CFLAGS = -DBASEDIR=\"/tmp/acl-ptest\"
  libtestlookup_la_LDFLAGS = -rpath $(abs_builddir)
  
- AM_TESTS_ENVIRONMENT = PATH="$(abs_top_builddir):$$PATH";
+ # Make sure translations don't break tests when matching output.
diff --git a/meta/recipes-support/attr/acl_2.3.1.bb b/meta/recipes-support/attr/acl_2.3.2.bb
similarity index 94%
rename from meta/recipes-support/attr/acl_2.3.1.bb
rename to meta/recipes-support/attr/acl_2.3.2.bb
index 9badd33254..6178473873 100644
--- a/meta/recipes-support/attr/acl_2.3.1.bb
+++ b/meta/recipes-support/attr/acl_2.3.2.bb
@@ -19,10 +19,9 @@  SRC_URI = "${SAVANNAH_GNU_MIRROR}/acl/${BP}.tar.gz \
            file://run-ptest \
            file://0001-tests-do-not-hardcode-the-build-path-into-a-helper-l.patch \
            file://0001-test-patch-out-failing-bits.patch \
-           file://0001-chacl-Use-portable-version-of-dirent-and-readdir.patch \
            "
 
-SRC_URI[sha256sum] = "760c61c68901b37fdd5eefeeaf4c0c7a26bdfdd8ac747a1edff1ce0e243c11af"
+SRC_URI[sha256sum] = "5f2bdbad629707aa7d85c623f994aa8a1d2dec55a73de5205bac0bf6058a2f7c"
 
 inherit autotools gettext ptest