diff mbox series

[meta-python,2/4] python3-pybind11: Prune redundant inherit

Message ID 20240214082449.3498259-2-niko.mauno@vaisala.com
State Accepted
Headers show
Series [meta-python,1/4] python3-pybind11: Amend HOMEPAGE | expand

Commit Message

Niko Mauno Feb. 14, 2024, 8:24 a.m. UTC
From: Niko Mauno <niko.mauno@vaisala.com>

Inheriting setuptools3 implies the inherit of python3native, so drop
the latter inherit as redundant.

Signed-off-by: Niko Mauno <niko.mauno@vaisala.com>
---
 meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Tim Orling Feb. 15, 2024, 3:30 a.m. UTC | #1
On Wed, Feb 14, 2024 at 12:25 AM Niko Mauno via lists.openembedded.org
<niko.mauno=vaisala.com@lists.openembedded.org> wrote:

> From: Niko Mauno <niko.mauno@vaisala.com>
>
> Inheriting setuptools3 implies the inherit of python3native, so drop
> the latter inherit as redundant.
>
according to
https://github.com/pybind/pybind11/blob/8b48ff878c168b51fe5ef7b8c728815b9e1a9857/pyproject.toml#L3
we should drop setuptools3 and inherit pyyhin_setuptools_build_meta

>
> Signed-off-by: Niko Mauno <niko.mauno@vaisala.com>
> ---
>  meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta-python/recipes-devtools/python/
> python3-pybind11_2.11.1.bb b/meta-python/recipes-devtools/python/
> python3-pybind11_2.11.1.bb
> index e919e7dcc..442837199 100644
> --- a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
> +++ b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
> @@ -13,7 +13,7 @@ S = "${WORKDIR}/git"
>
>  EXTRA_OECMAKE =  "-DPYBIND11_TEST=OFF"
>
> -inherit cmake setuptools3 python3native
> +inherit cmake setuptools3
>
>  PIP_INSTALL_DIST_PATH = "${S}/dist"
>  PIP_INSTALL_PACKAGE = "pybind11"
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108735):
> https://lists.openembedded.org/g/openembedded-devel/message/108735
> Mute This Topic: https://lists.openembedded.org/mt/104349532/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj Feb. 15, 2024, 3:39 a.m. UTC | #2
On Wed, Feb 14, 2024 at 7:30 PM Tim Orling <ticotimo@gmail.com> wrote:

>
>
> On Wed, Feb 14, 2024 at 12:25 AM Niko Mauno via lists.openembedded.org
> <niko.mauno=vaisala.com@lists.openembedded.org> wrote:
>
>> From: Niko Mauno <niko.mauno@vaisala.com>
>>
>> Inheriting setuptools3 implies the inherit of python3native, so drop
>> the latter inherit as redundant.
>>
> according to
>
> https://github.com/pybind/pybind11/blob/8b48ff878c168b51fe5ef7b8c728815b9e1a9857/pyproject.toml#L3
> we should drop setuptools3 and inherit pyyhin_setuptools_build_meta
>

Good point I think that could be added as a new patch


>> Signed-off-by: Niko Mauno <niko.mauno@vaisala.com>
>> ---
>>  meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/meta-python/recipes-devtools/python/
>> python3-pybind11_2.11.1.bb b/meta-python/recipes-devtools/python/
>> python3-pybind11_2.11.1.bb
>> index e919e7dcc..442837199 100644
>> --- a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
>> +++ b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
>> @@ -13,7 +13,7 @@ S = "${WORKDIR}/git"
>>
>>  EXTRA_OECMAKE =  "-DPYBIND11_TEST=OFF"
>>
>> -inherit cmake setuptools3 python3native
>> +inherit cmake setuptools3
>>
>>  PIP_INSTALL_DIST_PATH = "${S}/dist"
>>  PIP_INSTALL_PACKAGE = "pybind11"
>> --
>> 2.39.2
>>
>>
>>
>>
>>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108748):
> https://lists.openembedded.org/g/openembedded-devel/message/108748
> Mute This Topic: https://lists.openembedded.org/mt/104349532/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Niko Mauno Feb. 26, 2024, 11:46 a.m. UTC | #3
On 15.2.2024 5.39, Khem Raj wrote:
> On Wed, Feb 14, 2024 at 7:30 PM Tim Orling <ticotimo@gmail.com 
> <mailto:ticotimo@gmail.com>> wrote:
> 
>     On Wed, Feb 14, 2024 at 12:25 AM Niko Mauno via
>     lists.openembedded.org
>     <http://lists.openembedded.org/
> 
>         From: Niko Mauno <niko.mauno@vaisala.com
>         <mailto:niko.mauno@vaisala.com>>
> 
>         Inheriting setuptools3 implies the inherit of python3native, so drop
>         the latter inherit as redundant.
> 
>     according to
>     https://github.com/pybind/pybind11/blob/8b48ff878c168b51fe5ef7b8c728815b9e1a9857/pyproject.toml#L3 <https://github.com/pybind/pybind11/blob/8b48ff878c168b51fe5ef7b8c728815b9e1a9857/pyproject.toml#L3
>     we should drop setuptools3 and inherit pyyhin_setuptools_build_meta
> 
> 
> Good point I think that could be added as a new patch

Thanks, submitted a new series for addressing this issue: 
https://patchwork.yoctoproject.org/project/oe/list/?series=22759
-Niko
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
index e919e7dcc..442837199 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
@@ -13,7 +13,7 @@  S = "${WORKDIR}/git"
 
 EXTRA_OECMAKE =  "-DPYBIND11_TEST=OFF"
 
-inherit cmake setuptools3 python3native
+inherit cmake setuptools3
 
 PIP_INSTALL_DIST_PATH = "${S}/dist"
 PIP_INSTALL_PACKAGE = "pybind11"