diff mbox series

Add user space utility:dropwatch

Message ID 20240209142838.113213-1-chen_heyun@163.com
State Rejected, archived
Headers show
Series Add user space utility:dropwatch | expand

Commit Message

chenheyun Feb. 9, 2024, 2:28 p.m. UTC
we can enbale linux module(drop_monitor.ko),and use dropwatch
of user space utility to diagnose NetWorking packets are getting dropped.

Signed-off-by: chenheyun <chen_heyun@163.com>
---
 .../dropwatch/dropwatch_git.bb                | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100755 meta/recipes-extended/dropwatch/dropwatch_git.bb
diff mbox series

Patch

diff --git a/meta/recipes-extended/dropwatch/dropwatch_git.bb b/meta/recipes-extended/dropwatch/dropwatch_git.bb
new file mode 100755
index 0000000000..62a1eab777
--- /dev/null
+++ b/meta/recipes-extended/dropwatch/dropwatch_git.bb
@@ -0,0 +1,22 @@ 
+# Copyright (C) 2024 chenheyun <chen_heyun@163.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY  = "User space utility to diagnose to NetWorking packets are getting dropped"
+DESCRIPTION = "Dropwatch is an utility to interface to the kernel to monitor for dropped \
+               network packets"
+                   
+HOMEPAGE = "https://github.com/nhorman/dropwatch/"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+DEPENDS = "libnl readline libpcap binutils"
+
+PV = "1.0.0"
+
+SRC_URI = "git://github.com/nhorman/dropwatch/;branch=master;protocol=https"
+SRCREV = "853457b77dbc3d6665a379f3fe31ec53f11b6f61"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig gettext
+
+BBCLASSEXTEND = "native nativesdk"