diff mbox series

[meta-python] python3-werkzeug: upgrade 2.3.6 -> 3.0.1

Message ID 20240209090017.37658-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-werkzeug: upgrade 2.3.6 -> 3.0.1 | expand

Commit Message

Alper Ak Feb. 9, 2024, 9 a.m. UTC
Upstream provides a pyproject.toml which declares a flit_core.buildapi build backend for PEP-517 packaging instead of setuptools. Also, RDEPENDS updated according to it.

Removed CLEANBROKEN because it is not necessary.

Changelog:

Version 3.0.1

    Fix slow multipart parsing for large parts potentially enabling DoS attacks. CWE-407

Version 3.0.0

    Remove previously deprecated code.

    Deprecate the __version__ attribute. Use feature detection, or importlib.metadata.version("werkzeug"), instead.

    generate_password_hash uses scrypt by default.

    Add the "werkzeug.profiler" item to the WSGI environ dictionary passed to ProfilerMiddleware’s filename_format function. It contains the elapsed and time values for the profiled request.

    Explicitly marked the PathConverter as non path isolating.

Version 2.3.8

    Fix slow multipart parsing for large parts potentially enabling DoS attacks. CWE-407

Version 2.3.7

    Use flit_core instead of setuptools as build backend.

    Fix parsing of multipart bodies.

    Adjust index of last newline in data start.

    Parsing ints from header values strips spacing first.

    Fix empty file streaming when testing.

    Clearer error message when URL rule does not start with slash.

    Accept q value can be a float without a decimal part.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-werkzeug_2.3.6.bb          | 40 -------------------
 .../python/python3-werkzeug_3.0.1.bb          | 19 +++++++++
 2 files changed, 19 insertions(+), 40 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-werkzeug_2.3.6.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_2.3.6.bb b/meta-python/recipes-devtools/python/python3-werkzeug_2.3.6.bb
deleted file mode 100644
index 11441fca2..000000000
--- a/meta-python/recipes-devtools/python/python3-werkzeug_2.3.6.bb
+++ /dev/null
@@ -1,40 +0,0 @@ 
-SUMMARY = "The Swiss Army knife of Python web development"
-DESCRIPTION = "\
-Werkzeug started as simple collection of various utilities for WSGI \
-applications and has become one of the most advanced WSGI utility modules. \
-It includes a powerful debugger, full featured request and response objects, \
-HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
-cookie handling, file uploads, a powerful URL routing system and a bunch \
-of community contributed addon modules."
-HOMEPAGE = "http://werkzeug.pocoo.org/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
-
-PYPI_PACKAGE = "Werkzeug"
-
-SRC_URI[sha256sum] = "98c774df2f91b05550078891dee5f0eb0cb797a522c757a2452b9cee5b202330"
-
-inherit pypi python_setuptools_build_meta
-
-CLEANBROKEN = "1"
-
-RDEPENDS:${PN} += " \
-    ${PYTHON_PN}-datetime \
-    ${PYTHON_PN}-difflib \
-    ${PYTHON_PN}-email \
-    ${PYTHON_PN}-html \
-    ${PYTHON_PN}-io \
-    ${PYTHON_PN}-json \
-    ${PYTHON_PN}-logging \
-    ${PYTHON_PN}-netclient \
-    ${PYTHON_PN}-netserver \
-    ${PYTHON_PN}-numbers \
-    ${PYTHON_PN}-pkgutil \
-    ${PYTHON_PN}-pprint \
-    ${PYTHON_PN}-simplejson \
-    ${PYTHON_PN}-threading \
-    ${PYTHON_PN}-unixadmin \
-    ${PYTHON_PN}-misc \
-    ${PYTHON_PN}-profile \
-    ${PYTHON_PN}-markupsafe \
-"
diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb b/meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb
new file mode 100644
index 000000000..6e500dde8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "The comprehensive WSGI web application library"
+DESCRIPTION = "\
+Werkzeug started as simple collection of various utilities for WSGI \
+applications and has become one of the most advanced WSGI utility modules. \
+It includes a powerful debugger, full featured request and response objects, \
+HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
+cookie handling, file uploads, a powerful URL routing system and a bunch \
+of community contributed addon modules."
+HOMEPAGE = "https://werkzeug.palletsprojects.com"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
+
+SRC_URI[sha256sum] = "507e811ecea72b18a404947aded4b3390e1db8f826b494d76550ef45bb3b1dcc"
+
+inherit pypi python_flit_core
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-markupsafe \
+"