diff mbox series

[meta-ti,master,v2] gdbc6x: Fix kernel module to work on 6.6+

Message ID 20240208185446.1999-1-reatmon@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,master,v2] gdbc6x: Fix kernel module to work on 6.6+ | expand

Commit Message

Ryan Eatmon Feb. 8, 2024, 6:54 p.m. UTC
The "upstream" is not maintained, but this is an easy patch to get this
working again.  Still need to watch this for big breakages and rethink
supporting this recipe at that time.

Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
v2: Change Upstream-Status to Inactive-Upstream

 .../0002-Support-Linux-kernels-v6.6.patch     | 31 +++++++++++++++++++
 .../gdbc6x/gdbserverproxy-module-drv_git.bb   |  5 ++-
 2 files changed, 35 insertions(+), 1 deletion(-)
 create mode 100644 meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv/0002-Support-Linux-kernels-v6.6.patch
diff mbox series

Patch

diff --git a/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv/0002-Support-Linux-kernels-v6.6.patch b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv/0002-Support-Linux-kernels-v6.6.patch
new file mode 100644
index 00000000..1e897394
--- /dev/null
+++ b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv/0002-Support-Linux-kernels-v6.6.patch
@@ -0,0 +1,31 @@ 
+From: Ryan Eatmon <reatmon@ti.com>
+Date: Wed, 08 Feb 2024 10:43:00 -0500
+Subject: [PATCH] Support Linux kernels v6.6+
+
+gdb_write arg changed from int to unsigned int
+
+Upstream-Status: Inactive-Upstream
+
+Signed-off-by: Ryan Eatmon <reatmon@ti.com>
+---
+ kernel_module/gdbproxy-mod/gdbserverproxy.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/kernel_module/gdbproxy-mod/gdbserverproxy.c b/kernel_module/gdbproxy-mod/gdbserverproxy.c
+index 418b6db..4b1c676 100644
+--- a/kernel_module/gdbproxy-mod/gdbserverproxy.c
++++ b/kernel_module/gdbproxy-mod/gdbserverproxy.c
+@@ -496,8 +496,13 @@ static void gdb_close(struct tty_struct *tty, struct file *filp)
+  * 
+  *
+  */
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(6,6,0))
++static int gdb_write(struct tty_struct *tty,
++        const unsigned char *buf, unsigned int count)
++#else
+ static int gdb_write(struct tty_struct *tty,
+         const unsigned char *buf, int count)
++#endif
+ {
+      struct dsp_session *dsp = tty->driver_data;
+      int ret = 0;
diff --git a/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
index 60492f81..b68c4463 100644
--- a/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
+++ b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
@@ -7,7 +7,10 @@  MACHINE_KERNEL_PR:append = "b"
 PR = "${MACHINE_KERNEL_PR}"
 PV:append = "+git${SRCPV}"
 
-SRC_URI:append = " file://0001-Support-Linux-kernels-v5.15.patch;patchdir=../.."
+SRC_URI:append = "\
+    file://0001-Support-Linux-kernels-v5.15.patch;patchdir=../.. \
+    file://0002-Support-Linux-kernels-v6.6.patch;patchdir=../.. \
+"
 
 S = "${WORKDIR}/git/kernel_module/gdbproxy-mod"