diff mbox series

python3-numpy: upgrade 1.26.3 -> 1.26.4

Message ID 20240207185313.1654134-1-tgamblin@baylibre.com
State Accepted, archived
Commit 3296f9a13d16575ecd5b2dd0f95d94445b092c41
Headers show
Series python3-numpy: upgrade 1.26.3 -> 1.26.4 | expand

Commit Message

Trevor Gamblin Feb. 7, 2024, 6:53 p.m. UTC
Changelog: https://github.com/numpy/numpy/releases/tag/v1.26.4

Upgrade to pull in a variety of bug fixes.

The same number of ptests (6) fail as in 1.26.3, so no regression there.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 ...le-fallocate-on-32-bit-linux-platfor.patch | 51 -------------------
 ...umpy_1.26.3.bb => python3-numpy_1.26.4.bb} |  3 +-
 2 files changed, 1 insertion(+), 53 deletions(-)
 delete mode 100644 meta/recipes-devtools/python/python3-numpy/0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch
 rename meta/recipes-devtools/python/{python3-numpy_1.26.3.bb => python3-numpy_1.26.4.bb} (92%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-numpy/0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch b/meta/recipes-devtools/python/python3-numpy/0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch
deleted file mode 100644
index 0702b8499ac..00000000000
--- a/meta/recipes-devtools/python/python3-numpy/0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch
+++ /dev/null
@@ -1,51 +0,0 @@ 
-From 43b9b2626a59e8764f3bfb1d6b0d73b2d665584e Mon Sep 17 00:00:00 2001
-From: Ola x Nilsson <olani@axis.com>
-Date: Fri, 19 Jan 2024 10:26:41 +0100
-Subject: [PATCH] BUG: Use large file fallocate on 32 bit linux platforms
-
-Using a local prototype for fallocate instead of the fcntl.h header
-meant that the redirect triggered by -D_FILE_OFFSET_BITS=64 was not
-triggered.
-
-The prototypes in feature_detection_stdio.h should only be used by
-functions in setup_common.py. If they are used by the feature
-discovery code they might trigger false positives.
-
-Upstream-Status: Backport [https://github.com/numpy/numpy/commit/f49c6f9ea735cd7f718e74f8d637ffbbd3a7a03b]
-Signed-off-by: Ola x Nilsson <olani@axis.com>
-
----
- numpy/core/feature_detection_stdio.h | 3 +++
- numpy/core/src/multiarray/convert.c  | 5 +++--
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/numpy/core/feature_detection_stdio.h b/numpy/core/feature_detection_stdio.h
-index bc14d16..d8bbfbd 100644
---- a/numpy/core/feature_detection_stdio.h
-+++ b/numpy/core/feature_detection_stdio.h
-@@ -1,6 +1,9 @@
-+#define _GNU_SOURCE
- #include <stdio.h>
- #include <fcntl.h>
- 
-+#if 0 /* Only for setup_common.py, not the C compiler */
- off_t ftello(FILE *stream);
- int fseeko(FILE *stream, off_t offset, int whence);
- int fallocate(int, int, off_t, off_t);
-+#endif
-diff --git a/numpy/core/src/multiarray/convert.c b/numpy/core/src/multiarray/convert.c
-index 60c1a1b..8ec0aee 100644
---- a/numpy/core/src/multiarray/convert.c
-+++ b/numpy/core/src/multiarray/convert.c
-@@ -23,8 +23,9 @@
- #include "array_coercion.h"
- #include "refcount.h"
- 
--int
--fallocate(int fd, int mode, off_t offset, off_t len);
-+#if defined(HAVE_FALLOCATE) && defined(__linux__)
-+#include <fcntl.h>
-+#endif
- 
- /*
-  * allocate nbytes of diskspace for file fp
diff --git a/meta/recipes-devtools/python/python3-numpy_1.26.3.bb b/meta/recipes-devtools/python/python3-numpy_1.26.4.bb
similarity index 92%
rename from meta/recipes-devtools/python/python3-numpy_1.26.3.bb
rename to meta/recipes-devtools/python/python3-numpy_1.26.4.bb
index 326e2c35914..d11b03efc3d 100644
--- a/meta/recipes-devtools/python/python3-numpy_1.26.3.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.26.4.bb
@@ -12,9 +12,8 @@  SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
            file://0001-numpy-core-Define-RISCV-32-support.patch \
            file://fix_reproducibility.patch \
            file://run-ptest \
-           file://0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch \
            "
-SRC_URI[sha256sum] = "697df43e2b6310ecc9d95f05d5ef20eacc09c7c4ecc9da3f235d39e71b7da1e4"
+SRC_URI[sha256sum] = "2a02aba9ed12e4ac4eb3ea9421c420301a0c6460d9830d74a9df87efa4912010"
 
 GITHUB_BASE_URI = "https://github.com/numpy/numpy/releases"
 UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$"