diff mbox series

[1/1] bmap-tools: Add missing runtime dependency

Message ID 20240207165219.825246-2-vikas.katariya@arm.com
State Accepted, archived
Commit 5f449575be9986906e021706e248ee8340d7084d
Headers show
Series Add missing runtime dependency for bmap-tools recipe | expand

Commit Message

Vikas Katariya Feb. 7, 2024, 4:52 p.m. UTC
From: Vikas Katariya <vikas.katariya@arm.com>

Python3 module netrc is required by bmap-tools (v3.7), therefore add
`python3-misc` as runtime dependency.

Signed-off-by: Vikas Katariya <vikas.katariya@arm.com>
---
 meta/recipes-support/bmap-tools/bmap-tools_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Tim Orling Feb. 8, 2024, 4 a.m. UTC | #1
On Wed, Feb 7, 2024 at 8:52 AM <vikas.katariya@arm.com> wrote:

> From: Vikas Katariya <vikas.katariya@arm.com>
>
> Python3 module netrc is required by bmap-tools (v3.7), therefore add
> `python3-misc` as runtime dependency.


https://github.com/search?q=repo%3Aintel%2Fbmap-tools%20netrc&type=code

We could arguably create a python3-netrc sub package to minimize the added
files.

>
> Signed-off-by: Vikas Katariya <vikas.katariya@arm.com>
> ---
>  meta/recipes-support/bmap-tools/bmap-tools_git.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-support/bmap-tools/bmap-tools_git.bb
> b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
> index 9bbd7d51c8..ffb6ccfe99 100644
> --- a/meta/recipes-support/bmap-tools/bmap-tools_git.bb
> +++ b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
> @@ -24,7 +24,7 @@ PV = "${BASEVER}+git"
>  UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
>
>  # Need df from coreutils
> -RDEPENDS:${PN} = "python3-core python3-compression python3-mmap
> python3-setuptools python3-fcntl python3-six coreutils"
> +RDEPENDS:${PN} = "python3-core python3-compression python3-misc
> python3-mmap python3-setuptools python3-fcntl python3-six coreutils"
>
>  inherit setuptools3
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#195074):
> https://lists.openembedded.org/g/openembedded-core/message/195074
> Mute This Topic: https://lists.openembedded.org/mt/104222189/924729
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Richard Purdie Feb. 9, 2024, 4:57 p.m. UTC | #2
On Wed, 2024-02-07 at 20:00 -0800, Tim Orling wrote:
> 
> 
> On Wed, Feb 7, 2024 at 8:52 AM <vikas.katariya@arm.com> wrote:
> > From: Vikas Katariya <vikas.katariya@arm.com>
> > 
> > Python3 module netrc is required by bmap-tools (v3.7), therefore add
> > `python3-misc` as runtime dependency.
> > 
> 
> 
> https://github.com/search?q=repo%3Aintel%2Fbmap-tools%20netrc&type=code
> 
> We could arguably create a python3-netrc sub package to minimize the added files.

I don't want to add python-misc dependencies like this. Please can we
tweak the python module splitting to have a separate package for this,
then we can depend upon that.

Thanks,

Richard
Ross Burton Feb. 12, 2024, 5:27 p.m. UTC | #3
On 9 Feb 2024, at 16:57, Richard Purdie via lists.openembedded.org <richard.purdie=linuxfoundation.org@lists.openembedded.org> wrote:
> 
> On Wed, 2024-02-07 at 20:00 -0800, Tim Orling wrote:
>> 
>> 
>> On Wed, Feb 7, 2024 at 8:52 AM <vikas.katariya@arm.com> wrote:
>>> From: Vikas Katariya <vikas.katariya@arm.com>
>>> 
>>> Python3 module netrc is required by bmap-tools (v3.7), therefore add
>>> `python3-misc` as runtime dependency.
>>> 
>> 
>> 
>> https://github.com/search?q=repo%3Aintel%2Fbmap-tools%20netrc&type=code
>> 
>> We could arguably create a python3-netrc sub package to minimize the added files.
> 
> I don't want to add python-misc dependencies like this. Please can we
> tweak the python module splitting to have a separate package for this,
> then we can depend upon that.

python3-misc doesn’t have any heavy dependency chains, it’s just the catch-all of last resort.

Ross
Richard Purdie Feb. 12, 2024, 5:41 p.m. UTC | #4
On Mon, 2024-02-12 at 17:27 +0000, Ross Burton wrote:
> On 9 Feb 2024, at 16:57, Richard Purdie via lists.openembedded.org <richard.purdie=linuxfoundation.org@lists.openembedded.org> wrote:
> > 
> > On Wed, 2024-02-07 at 20:00 -0800, Tim Orling wrote:
> > > 
> > > 
> > > On Wed, Feb 7, 2024 at 8:52 AM <vikas.katariya@arm.com> wrote:
> > > > From: Vikas Katariya <vikas.katariya@arm.com>
> > > > 
> > > > Python3 module netrc is required by bmap-tools (v3.7), therefore add
> > > > `python3-misc` as runtime dependency.
> > > > 
> > > 
> > > 
> > > https://github.com/search?q=repo%3Aintel%2Fbmap-tools%20netrc&type=code
> > > 
> > > We could arguably create a python3-netrc sub package to minimize the added files.
> > 
> > I don't want to add python-misc dependencies like this. Please can we
> > tweak the python module splitting to have a separate package for this,
> > then we can depend upon that.
> 
> python3-misc doesn’t have any heavy dependency chains, it’s just the catch-all of last resort.

Fair enough, I think I was misremembering something about it needing a
lot of modules. Ideally it would get split but I'm ok with merging the
patch I guess.

Cheers,

Richard
Vikas Katariya Feb. 13, 2024, 8:54 a.m. UTC | #5
Just checking if rework of this patch is required? If not, please can this be merged?

Thanks,
Vikas Katariya

-----Original Message-----
From: Richard Purdie <richard.purdie@linuxfoundation.org> 
Sent: Monday, February 12, 2024 17:41
To: Ross Burton <Ross.Burton@arm.com>
Cc: Tim Orling <ticotimo@gmail.com>; Vikas Katariya <Vikas.Katariya@arm.com>; openembedded-core@lists.openembedded.org
Subject: Re: [OE-core] [PATCH 1/1] bmap-tools: Add missing runtime dependency

On Mon, 2024-02-12 at 17:27 +0000, Ross Burton wrote:
> On 9 Feb 2024, at 16:57, Richard Purdie via lists.openembedded.org <richard.purdie=linuxfoundation.org@lists.openembedded.org> wrote:
> > 
> > On Wed, 2024-02-07 at 20:00 -0800, Tim Orling wrote:
> > > 
> > > 
> > > On Wed, Feb 7, 2024 at 8:52 AM <vikas.katariya@arm.com> wrote:
> > > > From: Vikas Katariya <vikas.katariya@arm.com>
> > > > 
> > > > Python3 module netrc is required by bmap-tools (v3.7), therefore 
> > > > add `python3-misc` as runtime dependency.
> > > > 
> > > 
> > > 
> > > https://github.com/search?q=repo%3Aintel%2Fbmap-tools%20netrc&type
> > > =code
> > > 
> > > We could arguably create a python3-netrc sub package to minimize the added files.
> > 
> > I don't want to add python-misc dependencies like this. Please can 
> > we tweak the python module splitting to have a separate package for 
> > this, then we can depend upon that.
> 
> python3-misc doesn’t have any heavy dependency chains, it’s just the catch-all of last resort.

Fair enough, I think I was misremembering something about it needing a lot of modules. Ideally it would get split but I'm ok with merging the patch I guess.

Cheers,

Richard
Ross Burton Feb. 13, 2024, 10:30 a.m. UTC | #6
On 13 Feb 2024, at 08:54, Vikas Katariya <Vikas.Katariya@arm.com> wrote:
> 
> Just checking if rework of this patch is required? If not, please can this be merged?

It’s queued to be merged.

Ross
diff mbox series

Patch

diff --git a/meta/recipes-support/bmap-tools/bmap-tools_git.bb b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
index 9bbd7d51c8..ffb6ccfe99 100644
--- a/meta/recipes-support/bmap-tools/bmap-tools_git.bb
+++ b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
@@ -24,7 +24,7 @@  PV = "${BASEVER}+git"
 UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
 
 # Need df from coreutils
-RDEPENDS:${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl python3-six coreutils"
+RDEPENDS:${PN} = "python3-core python3-compression python3-misc python3-mmap python3-setuptools python3-fcntl python3-six coreutils"
 
 inherit setuptools3